Hot running transmission solution? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 08-25-2012, 04:11 PM Thread Starter
YJames90
Registered User
 
YJames90's Avatar
2012 JK Wrangler 
 
Join Date: Jul 2007
Location: Dutchess County, NY
Posts: 6,979
Hot running transmission solution?

700R4 runs hot at around 240 using the engine coolant and trans combo radiator. Measurement is taken from the pan
(260 when crawling)

Engine coolant runs around 170-180

Seperated the 2 and am using this dedicated trans cooler thats mounted behind the front grill

Now trans runs around 210.

If I run the line to the combo radiator then the aux cooler will the trans temp drop because the coolant temp is lower then the trans temp?

Heres the2 coolers in the YJ

And some flex shots




Quote:
Originally Posted by Poke View Post
Spring Over is not for you.... yet





My 2.5 to 4.3 swap thread
http://www.jeepforum.com/forum/f12/4...begun-1237704/
YJames90 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Best water-proof.. differential, transmission, and transfer case vent solution? awalp TJ Wrangler Technical Forum 30 10-30-2014 10:53 AM
Are you running a transmission cooler and which one??? GEM1N1 JK Wrangler Technical Forum 38 09-17-2013 03:43 PM
Transmission running too cool? chadsmeltzer TJ Wrangler Technical Forum 3 01-18-2011 05:01 PM
running without transmission? brundz YJ Wrangler Technical Forum 6 02-22-2007 10:02 PM
Transmission inspection results, (After running in mud) pwcracer TJ Wrangler Technical Forum 4 08-30-2006 10:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome