JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   High oil pressure (http://www.jeepforum.com/forum/f12/high-oil-pressure-7179/)

Atropine 10-19-2001 11:26 AM

High oil pressure
 
My guage is reading high (pegged out 80+) oil pressure while im driving, When I let off the gas it drops down to to normal aound 40. Any clue what this might be?

glm 87 wrangler 10-19-2001 11:35 AM

Mine stays pegged out!But Im willing to bet $$$$$$
its your oil pressure sender unit call the dealer or auto parts see if they have "em"
and go from there.Alot less head ache down the road... ;)

evilpsych 10-19-2001 11:36 AM

replace your oil pressure switch that controls the gauge... $20.50 at AutoZone.
dealer says those go bad all the time...

should work, if not, post a reply.

Atropine 10-19-2001 12:58 PM

Thanks guys! I'll replace the sender unit. What I'm worried about is there is a lot of leaking now around the valve cover gasket. Also when I changed the oil I noticed oil splattered on the inside of the hood. It may have leaked and was thrown up by the fan( i hope) I hope its not something major. I also believe that one of the lifters is bad, it was like that when I bought it. It makes knocking noises at low RPM.

glm 87 wrangler 10-20-2001 11:29 AM

If you have a 258 i know there bad for leaking oil.Mine did very bad a first,added the cork type valve cover gasket.still leaks a little.tried the form a gasket only at first,the dealer suggested it over the cork
gasket but it leaked worse so went with the gasket.Now you did say it was blowing oil or getting kick up by the fan.Well check your PCV valves first,when my dad had it I fixed that problem,was doing the same thing found oil under the hood thought it was something
major but both PCV valves were clogged,check and make sure they rattle and they are clean.
They will have oil on them thats ok..Now the problem with the knocking.If you have the 258
I can say the JUICE BOX works thats the TFI
upgrade.Mine use to knock a low rpms even after the rebuild.So I up graded the ignition
and now it runs great.No more spark knocks at
2500 rpms and higher.Also upgraded the carb to a weber got rid of the made to fail carter
carb.I hope some of this helps you. ;)

Atropine 10-23-2001 05:52 AM

Well I took out the air filter yesterday and noticed oil in it, not a lot but enough to concern me. I took off the "PCV" valve and noticed that it is not a PCV valve at all. I found out that mine doesnt have a PCV valve but a CCV hose. The thing was plugged tight. I cleaned it out and replaced it and found that the oil pressure dropped. I was all excited and drove to work today and the oil pressure went right back up again. It is currently at about 80 plus and 40 when its idling. I want to replace the oil pressure sender unit but noone seems to have this part. Plus still concerned with all the oil.

glm 87 wrangler 10-23-2001 06:40 AM

ok you have a ccv.Did you check both,not sure if you have 2 or 1.You may have one that
is big and another that will be small check and clean both again to make sure they are free.If the crank case breather gets cloged,it will back up so when you clean it the stuff at the bottom tends to back up. So
when you take off again same thing happens,keep cleaning and if you have the small thin hose check it too,cant rember if the small ever glogged or not..well keep me posted I think we are getting close,just keep jogging my memory..Just harder when not there

glm 87 wrangler 10-24-2001 06:22 AM

Well the only thing i can really tell you is
that you may have blow by.I would do a compression test on all cylinders first and go from there.Do you have a lot of miles on the jeep?

Atropine 10-24-2001 07:18 AM

yea theres about 113K miles on it. I replaced the CCV hose and cleaned out the valve that goes into the intake manifold. No luck. The jeep still rides OK and there doesnt seem to be any lack of HP. However it was like this when I bought the jeep. I don't think I have the tools to do a compression test. Is it pretty complicated? I am still going to replace the sender unit first. Oh yea thanks for all the help!!!


The time now is 01:10 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.