Help with starting - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Help with starting

Smittybilt Products at Oconee Off-Road!Alloy USA Still AvailableCurrie Currectlync Steering Upgrade Kits and Currie Anti-R

Reply
Unread 05-25-2012, 12:04 AM   #1
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
Help with starting

I just bought a 1992 jeep and I am trying to get it running again. I am getting no spark at the coil. I tested and got current to the plug to the coil. I have replaced the plugs,wires,rotor,rotor cap, and coil.

Also on the fuel rail test port I get no fuel when i press it and crank the engine.
When I turn the key to the on postion the check engine light does not come on. Also I hooked a code reader up and it failed to link with the jeep.

I do have a crankshaft position sensor coming in the morning just incase thats it.

What else can I do or what could it be?

cw_myers is offline   Reply With Quote
Unread 05-25-2012, 07:22 AM   #2
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,402
If reader not seeing computer, you got a wiring issue or computer issue... Which engine do you have?
Jeepsr4me is online now   Reply With Quote
Unread 05-25-2012, 12:19 PM   #3
J-Quad
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2008
Location: Mid-Michigan
Posts: 369
CWM,

I see from your profile you've got the 4.0 6-cylinder engine, is that still correct?
Possibly, but not likely, that your Check Engine Light (CEL) bulb has burned out. I'd change it with a known good light bulb to eliminate that as the problem.

I'm pretty sure the 4.0L were equipped with an electric fuel pump. If so, leave it stand for 10 minutes then turn the key on - you should be able to hear your electric fuel pump run for a few seconds (pressuring up) the fuel supply line. You may need to have a helper turn the key to 'on' while you stand back by the fuel fill spout listening for it as it can sometimes be fairly quiet.

However, based on what you've said earlier, I'm leaning toward either some blown relays/fuses or your Electronic Computer Module (ECM) being bad.... if it is your ECM, it may be fixable or may need to be replaced. If possible, switch it out with a known good unit and try it.

J-Quad
__________________
-- '95 YJ, 4-cyl, 5-speed.
From Dec-Mar, it wears an 80" snowplow. From Apr-Nov, it gets muddy on the 2-tracks!
"War does not determine who is right, war determines who is left."
J-Quad is offline   Reply With Quote
Unread 05-25-2012, 07:32 PM   #4
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,076
Quote:
Originally Posted by cw_myers View Post
I just bought a 1992 jeep and I am trying to get it running again. I am getting no spark at the coil. I tested and got current to the plug to the coil. I have replaced the plugs,wires,rotor,rotor cap, and coil.

Also on the fuel rail test port I get no fuel when i press it and crank the engine.
When I turn the key to the on postion the check engine light does not come on. Also I hooked a code reader up and it failed to link with the jeep.

I do have a crankshaft position sensor coming in the morning just incase thats it.

What else can I do or what could it be?
If the crank senser is bad you get no fuel or spark...BUT your CEL is not lighing up. Before you throw any more parts at this YJ you need to check for a good CEL bulb.

Once you determine that the bulb is there and it is good, turn your ignition to the ON position. The CEL should go on for a few seconds. If it does then try to start the YJ up.

If the CEL does not light up turn the ignion to the ON position and let it stay there for anywhere up to three or four minutes. IF the CEL lights up after a while then you have a failing 'brain' AKA; ECU, PCM, ECM The brain has bad capacitors and that can be fixed.
__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-25-2012, 08:35 PM   #5
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
Yes it still is 6cyl 4.0... I listened for pump with my ear to the gas fill spout but never heard it. I did drop the tank today and checked the pump and it worked and pumped fuel. I also replaced the fuel relay today.
The CEL bulb is good switched it with the brake one that lights up when trying to start. I have left the ignion ON for 5 minutes or more and never saw the CEL come on.

Should I try another computer? NOt sure what else to try. I have the dash all apart and I am going to check all the wiring tomorrow to see if anything there could be wrong. I also have tested the fuses and checked for power to the fuse slots.
cw_myers is offline   Reply With Quote
Unread 05-25-2012, 08:52 PM   #6
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,076
Quote:
Originally Posted by cw_myers View Post
Yes it still is 6cyl 4.0... I listened for pump with my ear to the gas fill spout but never heard it. I did drop the tank today and checked the pump and it worked and pumped fuel. I also replaced the fuel relay today.
The CEL bulb is good switched it with the brake one that lights up when trying to start. I have left the ignion ON for 5 minutes or more and never saw the CEL come on.

Should I try another computer? NOt sure what else to try. I have the dash all apart and I am going to check all the wiring tomorrow to see if anything there could be wrong. I also have tested the fuses and checked for power to the fuse slots.
If the brain is getting power and it does not set off the CEL I'd say your capacitors are bad in your brain. Cheap test is swap out the brian with another one that is compatible
__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-26-2012, 07:32 AM   #7
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
Thnaks, I am getting another brain from another jeep. I'll have to wait till I get it. I also have gauges on the way since the temp and others in that cluster where broke out and I have the dash removed to check all the wiring out.

I'll post more on it when I find out more with another brain.
cw_myers is offline   Reply With Quote
Unread 05-26-2012, 02:12 PM   #8
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
Okay I was going through the dash wiring trying to figure out all the crap someone did to it.
I found a unknown wire that was spliced into a purple wire that came out of a light blue connector on top of the steering column(ignition switch???) that wire ran down and out a drain plug and was spliced into either the y/bk or the tan/black wire going to the fuel pump.
I know the fuel pump works but have failed to hear it when the key comes on.
Any diagrams that show the wires going to the fuel pump so I can trace them back.

Last edited by cw_myers; 05-26-2012 at 05:37 PM..
cw_myers is offline   Reply With Quote
Unread 05-26-2012, 06:34 PM   #9
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,076
Quote:
Originally Posted by cw_myers View Post
Okay I was going through the dash wiring trying to figure out all the crap someone did to it.
I found a unknown wire that was spliced into a purple wire that came out of a light blue connector on top of the steering column(ignition switch???) that wire ran down and out a drain plug and was spliced into either the y/bk or the tan/black wire going to the fuel pump.
I know the fuel pump works but have failed to hear it when the key comes on.
Any diagrams that show the wires going to the fuel pump so I can trace them back.
Power for the fuel pump comes from the fuel pump relay. You sound like you have some 'creative' wiring in your YJ. I don't have any diagrams for a
'92YJ but depending on how much 'electrical creativity' the PO took with this YJ you might end up need a FSM for a'92 YJ. Maybe some othe member can help along those lines. You need to find all the non factory wiring and atttempt to understand what the PO was trying to do....poorly.
__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-26-2012, 07:47 PM   #10
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
Ok think I got all the wiring thats not suppose to be in there out of it. I did ohms the wire from the fuel pump relay to the plug for the fuel pump and it checked out ok. Now just waiting for the computer to see if thats the problem.
cw_myers is offline   Reply With Quote
Unread 05-27-2012, 06:51 AM   #11
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,076
If you checked the bulb for the CEL and it was OK but the CEL does not light up either you have no power to the PCM (brain) or it has bad capacitors.

Pull the PCM plug and check for power to it at pin #3, & #9 with the ignition in the ON position. This diagram is for a '95 4.0 so the wire colors are different but I am fairly sure that the pin outs are the same. and pi #3 & #9 do the same thing if you are running a 2.5.

EDIT IF you have no power to #3 you may have a blown fuse.

__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-27-2012, 06:52 AM   #12
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,076
Quote:
Originally Posted by laybackman View Post
If you checked the bulb for the CEL and it was OK but the CEL does not light up either you have no power to the PCM (brain) or it has bad capacitors.

Pull the PCM plug and check for power to it at pin #3, & #9 with the ignition in the ON position. This diagram is for a '95 4.0 so the wire colors are different but I am fairly sure that the pin outs are the same. and pi #3 & #9 do the same thing if you are running a 2.5.

You can also check to see if you are getting a 5 volt and an 8 volt output IF you are in fact getting power to the PCM.
__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-27-2012, 09:56 AM   #13
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
OK while waiting for a brain to come in. I noticed the O2 sensor wires are cut at the sensor and the other end is tied to a cross arm. I am going to replace it with the Bosch universal one but want to make sure of the wiring. is this the correct way to wire it?
Jeep has: O2 sensor:
black + black
gray + gray
green/black + white
black/red(or a brown) + white

Thanks for your help just want to get it running soon!!
cw_myers is offline   Reply With Quote
Unread 05-28-2012, 07:34 PM   #14
cw_myers
Registered User
1992 YJ Wrangler 
 
Join Date: May 2012
Location: Brownwood, Texas
Posts: 34
Quote:
Originally Posted by laybackman View Post
You can also check to see if you are getting a 5 volt and an 8 volt output IF you are in fact getting power to the PCM.
Ok I did some more checking today. If I turn the key I get no spark and the fuel pump does not prime. I did a jumper on the fuel relay and the pump started running.
What else can I check while waiting for the brain to come in?
cw_myers is offline   Reply With Quote
Unread 05-28-2012, 07:53 PM   #15
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,076
Quote:
Originally Posted by cw_myers View Post
I just bought a 1992 jeep and I am trying to get it running again. I am getting no spark at the coil. I tested and got current to the plug to the coil. I have replaced the plugs,wires,rotor,rotor cap, and coil.

Also on the fuel rail test port I get no fuel when i press it and crank the engine.
When I turn the key to the on postion the check engine light does not come on. Also I hooked a code reader up and it failed to link with the jeep.

I do have a crankshaft position sensor coming in the morning just incase thats it.

What else can I do or what could it be?
Unless you have an OBDI code reader you will not get it to sync with the OBDI brain. No CEL when the bulb is good says the brain has bad capacitors IF there is power to the brain. SO, once the 'new' brain gets hooked up there may be nothing else to do.

I'll add (if I haven't already done so) sometimes the brain has bad capacitors and when you turn the ignition to ON the CEL does not light up.

Did you turn the ignition to ON and simply let it stay there for several minutes? Sometime that gets it to light up. You have to sit there and watch it the whole time. If it does light up try to start it up then.
__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Reply

Tags
crankshaft position , no spark
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.