HELP with power steering - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > HELP with power steering

ZONE 4.25" combo lift for TJ available at Rockridge4wWarn, Smitybilt, Engo, Rugged Ridge Winches at CCORRough Country Lift Kits and Parts!

Reply
Unread 04-16-2010, 07:31 PM   #1
wordo30
Registered User
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Bartlesville
Posts: 131
HELP with power steering

I was on my way to school and once i had gotten there my powersteering went out and i couldn't turn the wheel really easy. Then later that night i took it apart and checked the lines and they seem to be clear of anything that could clog them and then i put everything back together and then i follwed the insructions on how to bleed the system but that didn't work. The power steering works well when im driving it and the RPMs are at 2000 but then whenever i stop or let the RPms go down it gets hard to steer. My setup is a 1990 chevy 350 in a YJ. I am using the chevy pump and the jeep powersteering gearbox. is there some kind of pressure issues that can develop with this system or how can you detect a bad gearbox or bad pump? Please help

wordo30 is offline   Reply With Quote Quick reply to this message
Unread 04-16-2010, 07:36 PM   #2
jay-h
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2006
Location: , NJ
Posts: 4,458
My guess is a bad pump
jay-h is offline   Reply With Quote Quick reply to this message
Unread 04-16-2010, 08:44 PM   #3
wordo30
Registered User
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Bartlesville
Posts: 131
so you think that the pump is just not feeding enough pressure.
wordo30 is offline   Reply With Quote Quick reply to this message
Unread 04-16-2010, 09:05 PM   #4
burnout189
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2003
Location: Waynesboro PA
Posts: 623
Quote:
Originally Posted by jay-h View Post
My guess is a bad pump
x2


10char..
__________________
A full sized Fleet of Jeeps

BARNHART'S AUTO REPAIR
burnout189 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.