Help me help a friend please. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 09-19-2013, 06:10 PM Thread Starter
spottedfrog
Registered User
1979 CJ5 
 
Join Date: Sep 2010
Location: Grand Junction
Posts: 835
Help me help a friend please.

So I'm trying to help a friend long distance.
He has a '89 YJ SE 2.5L, 5 speed, owned since new and bone stock.
He said that It will randomly only get up to 20 mph. while driving and sometimes refuse to turn over.
He said that the vehicle was getting driven regularly until it developed problems.

I'm unfamiliar with the 2.5L and had thought that it was still using a carb, but apparently they are TBI.
It has new plugs/wires, starter.

I was thinking it could be possibly a problem with the vacuum advance, or with the ignition control module.
Maybe an O2 sensor?
did the 2.5L have a crank angle sensor?

What else would you suggest.
Thanks

spottedfrog is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-19-2013, 06:41 PM
scraper
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2013
Location: Minerva
Posts: 214
Does he have manual or Auto?

But honestly this could be a whole lot of things. Has he checked the error codes. I would start there. Let us know if we can pin point the problem area that way.
scraper is offline  
post #3 of 9 Old 09-19-2013, 06:42 PM
scraper
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2013
Location: Minerva
Posts: 214
NM on the manual or auto I just saw the 5 speed part in your post.
scraper is offline  
post #4 of 9 Old 09-19-2013, 06:46 PM Thread Starter
spottedfrog
Registered User
1979 CJ5 
 
Join Date: Sep 2010
Location: Grand Junction
Posts: 835
I don't think he has access to a code reader.
could also be a clogged fuel filter.
normally on a vehicle this old I'd suspect the filter, and vac lines???
spottedfrog is offline  
post #5 of 9 Old 09-19-2013, 07:07 PM
mudsweatNgearz
Registered User
1987 YJ Wrangler 
 
Join Date: Aug 2011
Location: Tucson
Posts: 510
there is no vac advance on FI

I wondered why the baseball kept getting bigger and bigger....then it hit me!
mudsweatNgearz is offline  
post #6 of 9 Old 09-19-2013, 07:16 PM
scraper
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2013
Location: Minerva
Posts: 214
Not 100% sure about an 89 but I don't think he needs any tools to check the fault codes. Follow this link

http://www.jeepforum.com/forum/f12/h...codes-1257145/
scraper is offline  
post #7 of 9 Old 09-19-2013, 07:28 PM
bigbossd1030
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2010
Location: Edmonton, AB
Posts: 2,514
Yup, key trick should wok just fine.
Also, could be clogged cat?

/l ,[____],
l----L-[]lllllll[]-
()_)-()_)--o)_)

OFFICIAL JEEPER
Any Jeepers in Edmonton, AB
I am on channel 33.

I live, I ride, I am JEEP.
bigbossd1030 is offline  
post #8 of 9 Old 09-19-2013, 07:44 PM Thread Starter
spottedfrog
Registered User
1979 CJ5 
 
Join Date: Sep 2010
Location: Grand Junction
Posts: 835
Thanks every one.
I know it can be any one of a lot tof things, that's what I'm having a hard time with especially long distance. I was hoping to narrow it down to issues that seem to come up with this model.
spottedfrog is offline  
post #9 of 9 Old 09-20-2013, 08:47 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,811
No code reading for the 89. It was pre OBD I. You need to narrow it down. When it isn't starting you said it doesnt turn over. Do you mean the starter doesn't work?
Que89YJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome