Help! Injector issues! - Page 2 -

LinkBack Thread Tools
post #16 of 17 Old 08-26-2011, 02:11 PM
Web Wheeler
1991 YJ Wrangler 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
Far easier to just unhook the batt for 5 mins. This resets the computer and forces it to learn the new setup.

oldtime_ironman is offline  
Sponsored Links
post #17 of 17 Old 08-26-2011, 11:48 PM
Registered User
1993 YJ Wrangler 
Join Date: Jun 2011
Location: Surprise,
Posts: 645
I fixed my rough idle I had. I think somewhere in my installation or removal of parts i made a hole in my FPR's vacuum hose. Taped it up for now until I hit the parts store tomorrow. Idled like a dream.
In one shot I did all the following mods, so it was down about 1.5 weeks:
New Oem plugs gapped .055
Accel low resistance wires
DUI blue cap/rotor with brass terminals
ford 19# injectors 280150556 (210cc @43.5)
pertronix coil
bored open intake to match gasket
62mm spacer and TB

Fired right up, no problem, ran great, just idled a little bad until I found that leak.

If you changed nothing else but the injectors, try your stock ones again. If that fixes it, try your other 4 from that set. If those don't work, you're more than welcome to try my other 4 injectors. Figure 20 shipped priority usps.

93' YJ 2.5L, 4.88's, 8.8, E-Locker & LSD
mrdeath2000 is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
help! no injector pulse, no current to injector kirkland1625 YJ Wrangler Technical Forum 3 02-25-2012 07:10 PM
Injector Help captjanes TJ Wrangler Technical Forum 3 02-03-2011 09:20 PM
Injector Help J33Pyj YJ Wrangler Technical Forum 13 07-19-2008 11:04 PM
Gas leaking around injector, o-ring or injector itself? hedrinbc TJ Wrangler Technical Forum 8 05-09-2007 08:13 PM
Think it is the injector? Mr. Tobes YJ Wrangler Technical Forum 2 06-04-2006 06:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome