HELP!! 88 6cyl with no spark - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > HELP!! 88 6cyl with no spark

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 06-04-2002, 11:51 AM   #1
JeepsterDave
Registered User
 
Join Date: Jun 2002
Location: Cleveland, OH
Posts: 5
HELP!! 88 6cyl with no spark

hey guys, my 88 6 cyl won't start for me. I have the 4.2 with the carb. I replaced the coil, wires, plugs, cap&rotor, that primary coil unit under the dist cap, and even the ignition control module. The motor gets gas fine, but I am getting no spark. I don't think it has anything to do with the distributor because I can't even get spark coming from the coil wire. Everybody I've talked to at the parts stores thinks its the ICM, but I just replaced that...no luck. Help please!

JeepsterDave is offline   Reply With Quote
Unread 06-04-2002, 12:20 PM   #2
Plink
Registered User
 
Join Date: Apr 2002
Location: Spotsylvania VA
Posts: 770
Dave, I had the same problem with my 87 carbed 4.2. It sounds like there is a short. There is a wire that runs from the starter solenoid to the coil. The problem that I had is that the connectors on the starter sol (the small ones not the battery cable or the cable that goes to the starter). The connectors were VERY rusty and brittle. I replaced the connectors and basically checked every wire splice in the wiring harness. If your connections are fine then it might be the computer (I doubt it's the computer). From waht I've read YJs are notorious for shorts. It sucks but it's best to take your time and check all the connections and wires. Just take your time. You'll find it.
__________________
[FONT=tahoma][SIZE=3][COLOR=black][B]87 YJ 4.2[/B][/COLOR][/SIZE][/FONT]
[B]2" BL, 2" Shackle, 1.5" Black Diamond and Junk[/B]
[B]31 MTRs on MOABs[/B]
[B]Need new front and rear bumpers[/B]
[B]HAM: KB3JQS[/B]
Plink is offline   Reply With Quote
Unread 06-04-2002, 06:55 PM   #3
FLHT_FXRS_YJ
Registered User
 
Join Date: Mar 2001
Location: Michigan
Posts: 472
Is the ICM that you replaced the one that sits on the drivers side fender near the firewall? That's what gave me all kinds of problems when I had no spark and replaced everything else like you did.
__________________
89' YJ - 4.2 - NV4500 - NP231w/sye - 1" Body Lift - 2 1/2" Rancho Suspension Lift - 31" Firestone MTR - AR Outlaw II - Tomken Bumpers F & R - Warn 8000 front - Warn 6000 rec. mount rear - FlowFit Seats - Tom Woods Rear & Custom 2" front driveshafts
FLHT_FXRS_YJ is offline   Reply With Quote
Unread 06-04-2002, 09:18 PM   #4
JeepsterDave
Registered User
 
Join Date: Jun 2002
Location: Cleveland, OH
Posts: 5
Yes, the ignition control module (ICM) I replaced was the one on the drivers' side fenderwell...under the coolant overflow tank.
JeepsterDave is offline   Reply With Quote
Unread 06-05-2002, 11:45 AM   #5
avittum
Registered User
 
Join Date: Oct 2001
Location: Virginia Tech
Posts: 16
have you checked the JEEP's brain box??? its located in the dash on the passanger side(pain to get to)... same thing happened to me, and after being frustrated till i was ready to push the jeep off a cliff, i took it to a shop, sure enough, they changed the box and it works fine
avittum is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.