Help! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 05-24-2013, 08:24 PM Thread Starter
daddyyj
Registered User
1995 YJ Wrangler 
 
Join Date: May 2013
Location: Biloxi
Posts: 3
Help!

I have a 1995 yj 4.0 automatic transmission I went in the water ok. had my transmission rebuilt done now when I drive for about 10 min the engine light comes on then it won't start I put a new starter on and it started once now when I turn the key nothing at all happens all the lights and everything come on could it be something with the rebuilt transmission? It has never done this ever I even drove around for a month after the water issue. I have 1500.00 into this I'm getting frustrated please help!

daddyyj is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-25-2013, 03:45 AM
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 8,626
neutral safety switch could be the no start issue. the engine light, you need to have the codes ran.
Jeepsr4me is online now  
post #3 of 3 Old 05-25-2013, 09:08 AM
XJ93
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: Michigan
Posts: 1,539
What Jeepers4me said. Your check engine light will not come on for a transmission issue on an OBD1 vehicle. That check engine light is pretty much for emissions issues. May have water damage in your cat, and I would imagine that you would have some residual damage from water to the neutral safety starter switch. Yes, even a month later as now that water has had time to properly corrode connections inside the switch.
XJ93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome