Heater Upgrade Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Heater Upgrade Problems

XJ Rail Sale!The Ruffstuff NOT Universal 4 Link Kit!Vanco Big Brake Kit Promotion!

Reply
Unread 10-25-2005, 01:12 PM   #1
wolf3902
Registered User
 
Join Date: May 2005
Location: NE Ohio
Posts: 1,138
Heater Upgrade Problems

I did the heater blower upgrade this past weekend. Everything went well and I put a new core in while I was in there.
The problem is that the next day I started it and the low speed was not blowing at all. turned it up to medium and high and back a few times and it finally started blowing on low. However, it is not blowing as strong on low as when I first installed it. Not even as good as the old motor. Med. an High are still good and more powerful than the old blower.
Any ideas of what to check or replace?

__________________
'93 YJ 2.5 Jasper; 5 speed
All stock, waiting to be reborn.
6/19/05 ...2" BDS suspension lift...the rebirth has begun!!!

ONE NATION, UNDER G O D
Support It, or Leave It!
wolf3902 is offline   Reply With Quote Quick reply to this message
Unread 10-25-2005, 05:36 PM   #2
wolf3902
Registered User
 
Join Date: May 2005
Location: NE Ohio
Posts: 1,138
I'm sure it is some sort of resistance pack of sorts, anyone know where to find this part on the Jeep? The motor only has one hot and one ground going to it, so it isn't in there.
__________________
'93 YJ 2.5 Jasper; 5 speed
All stock, waiting to be reborn.
6/19/05 ...2" BDS suspension lift...the rebirth has begun!!!

ONE NATION, UNDER G O D
Support It, or Leave It!
wolf3902 is offline   Reply With Quote Quick reply to this message
Unread 10-26-2005, 12:48 AM   #3
Tshark299
Registered User
1987 YJ Wrangler 
 
Join Date: Mar 2004
Location: Upstate NY
Posts: 2,343
The resistors on mine are mounted in the air tube coming down from the cowl vent that connects to the top of the heater assembly, behind the right side of the dash.
__________________
'87 YJ Laredo - 4.0L, AX-15, NP231, 4.10s: 3.5" BDS, 31" Muds

'95 XJ - Donated drive train to the YJ, Parted out the rest

'51 CJ-3A - Buick 225 V6: Painless Wiring Harness, Warn Overdrive & Hubs, 2" Lift, 31" Muds
Tshark299 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.