JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   heater fuse keeps blowing (http://www.jeepforum.com/forum/f12/heater-fuse-keeps-blowing-550819/)

blamejane2 04-25-2008 06:14 PM

heater fuse keeps blowing
 
I just replaced the blown fuse for my heater. With a new fuse in place I tried the heater, and again nothing...sure enough I've blown another fuse. After installing another fuse I started the jeep and then stopped it (without turning on the heater). I checked and the fuse was blown again, just by starting the jeep.

Does anyone have an ideas where/what I should look at?

coshooter 04-25-2008 09:50 PM

Possibly a bad switch that's got an internal short. If you use an ohm meter and test from the switch side of the fuse plug (not the side with 12v coming from the battery) to a ground on the jeep and have continuity that would indicate a short either between the fuse and the switch or in the switch itself.

blamejane2 04-25-2008 10:02 PM

Thanks coshooter. How do I tell which side of the fuse plug is the switch side, versus the side coming from the 12v battery)?

xeroid81 04-26-2008 05:37 PM

Are you putting the right amp fuse in there?

blamejane2 04-26-2008 06:16 PM

yes, it calls for 25 amps.

coshooter 04-26-2008 07:58 PM

Quote:

Originally Posted by blamejane2 (Post 5138648)
Thanks coshooter. How do I tell which side of the fuse plug is the switch side, versus the side coming from the 12v battery)?


Use a test light or voltmeter and see which side of the fuse plug has 12v to a frame ground with the key in the on position.

xeroid81 04-27-2008 08:48 AM

It sounds like a short to the motor from the switch or the relay if it's on the load side.

blamejane2 04-27-2008 01:18 PM

I have continutiy at the fuse when testing the switch side. I disconnected the heater switch and checked again, the fuse still has continuity. I disconnected the a/c switch and still we have continuity.

Any ideas?

blamejane2 04-27-2008 04:10 PM

There's supposed to be a diode tapped in the wiring harness somewhere near the wiper switch t/o.

Does any one know where this diode is? I need to see if this diode was blown when my pcm fried. I'm trying to trace fuse #12 dk green wire, which is supposed to have a diode.

Any help would be awesome.


The time now is 01:22 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.