heat/vent fan not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > heat/vent fan not working

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 04-26-2007, 06:53 PM   #1
olyjeep
Registered User
1997 TJ Wrangler 
 
Join Date: May 2005
Location: Tampa, FL
Posts: 373
heat/vent fan not working

I haven't used the heat or fan in general for a few weeks but when I was running hot the other day, I went to turn the heat on to see if that would cool it off a little. Low and behold, the fan is not working at all on any speed.

Only thing I did recently was to pull the gauge cluster to clean the contacts on the oil pressure gauge but I don't think I messed anything up below it.

I checked the fuse and it is ok, and I pulled and inspected the connector behind the fan switch, seems to be connecting ok.

Any other things I should check?

__________________
1997 Sport, 4.0, Auto
2" BDS Lift
31's
olyjeep is offline   Reply With Quote
Unread 04-26-2007, 08:42 PM   #2
rustywrangler
Got my eye on you.....
 
rustywrangler's Avatar
 
Join Date: Apr 2005
Location: Syracuse, NY
Posts: 18,612
What setting do you have it set on? If its on vent it does not blow air on that setting.
__________________

Congenital Heart Disease is a reality for me, BOTH of my children have it. Please read up and become aware for future generations

Lydia Ann-Acquired 08/05/05 Open Heart surgery 08/10/05
Jacob Patrick-Acquired 01/17/08 Open Heart surgery 02/15/08
rustywrangler is offline   Reply With Quote
Unread 04-27-2007, 07:14 AM   #3
olyjeep
Registered User
1997 TJ Wrangler 
 
Join Date: May 2005
Location: Tampa, FL
Posts: 373
I tried it on all the settings but still no fan.
__________________
1997 Sport, 4.0, Auto
2" BDS Lift
31's
olyjeep is offline   Reply With Quote
Unread 04-27-2007, 07:33 AM   #4
ltdanyj
Registered User
2004 TJ Wrangler 
 
Join Date: Feb 2006
Location: Manassas, VA
Posts: 570
I just had the same problem yesterday!!! turn your key on, but don't start your engine... Now turn your heater/fan on, and watch your voltmeter. Does it drop? If so, your motor is jammed... I pulled the blower cover, and found a PEN that looked 10 years old.... Everything is hunky dory now....
ltdanyj is offline   Reply With Quote
Unread 04-27-2007, 08:10 AM   #5
olyjeep
Registered User
1997 TJ Wrangler 
 
Join Date: May 2005
Location: Tampa, FL
Posts: 373
Hmmm, I'll have to check that out. Where is the blower motor located at anyway? I don't have the Jeep nearby right now.
__________________
1997 Sport, 4.0, Auto
2" BDS Lift
31's
olyjeep is offline   Reply With Quote
Unread 04-27-2007, 08:43 AM   #6
ltdanyj
Registered User
2004 TJ Wrangler 
 
Join Date: Feb 2006
Location: Manassas, VA
Posts: 570
passenger footwell, next to the kickpanel
ltdanyj is offline   Reply With Quote
Unread 04-27-2007, 09:53 AM   #7
olyjeep
Registered User
1997 TJ Wrangler 
 
Join Date: May 2005
Location: Tampa, FL
Posts: 373
Thanks! I'll check when I get home today.
__________________
1997 Sport, 4.0, Auto
2" BDS Lift
31's
olyjeep is offline   Reply With Quote
Unread 04-27-2007, 09:02 PM   #8
olyjeep
Registered User
1997 TJ Wrangler 
 
Join Date: May 2005
Location: Tampa, FL
Posts: 373
Quote:
Originally Posted by ltdanyj
I just had the same problem yesterday!!! turn your key on, but don't start your engine... Now turn your heater/fan on, and watch your voltmeter. Does it drop? If so, your motor is jammed... I pulled the blower cover, and found a PEN that looked 10 years old.... Everything is hunky dory now....

Tried it and voltage does not drop at all. On to the next step. anyone else know what may have caused this? It was working a month ago...last time I needed the heater anyway...
__________________
1997 Sport, 4.0, Auto
2" BDS Lift
31's
olyjeep is offline   Reply With Quote
Unread 04-28-2007, 08:41 AM   #9
timatoe
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2006
Location: Grass Valley California
Posts: 13,458
Open the hood and look under the battery, you'll see the back of the blower motor sticking through the firewall. It should have a orange (I think) wire on a spade terminal. If it's not there = no power to the motor. Guess how many ways I tried troubleshooting the switch before finding this???
__________________
Quote:
Originally Posted by George Orwell
We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm.
timatoe is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.