Has anyone used a LUK clutch kit? - Page 3 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #31 of 34 Old 01-03-2012, 01:59 PM
lobukjeep
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2008
Location: maryland
Posts: 493
We use Valeo clutches at work in our trucks.They suck.Are drivers kept ripping the centers out of them.WE have also used LUK.They were better.We then switched to Phoenix Friction.They were great,took lots of abuse.Never ripped the center out of one of them.Buuuuut then.....We got crappy flywheels from them and they said it was the way we were installing them.lol.So he just lost a huge account.Dumb dumb.


"We don't call you son 'cause your bright"
lobukjeep is offline  
Sponsored Links
Advertisement
 
post #32 of 34 Old 01-18-2012, 05:53 AM
tomjohn777
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2010
Location: back in the woods
Posts: 83
Good thread, I am also looking to replace my clutch and PEP Boys has LUK clutches for $129.I think I will stop in and get one this week. But something that was just mentioned makes me wonder. I only feel it slip in 3rd, the RPM's go up and the engine lags.Other gears seem fine, maybe I just don't notice it as much? But it recently started getting cold here and thats when I noticed it. Could it be something other than the clutch?
tomjohn777 is offline  
post #33 of 34 Old 02-26-2013, 02:28 PM
Scoobicon
Registered User
2005 TJ Wrangler 
 
Join Date: Sep 2011
Location: New Windsor
Posts: 32
Just put a LUK in yesterday, mainly because my throw-out was sounding a bit like a pencil sharpener on takeoff after 166k+. No complaints in the first 60 miles with the LUK. Hope to get 200k more out of this one.
Scoobicon is offline  
 
post #34 of 34 Old 02-26-2013, 02:35 PM
NHfireLJ
Web Wheeler
 
NHfireLJ's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2009
Location: Seacoast NH
Posts: 4,840
Running a LUK behind my stroker!!! Very happy

AUDREY...95 YJ UNLIMITED

LUCY...2005 Unlimited "LJ" Rubicon Sahara #495 Build thread.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SOLD

BETTY...94 SE, Stroker 4.6, 4.5,lift,35"s,D30 Aussie, 8.8. SOLD

YJOTM FEB 2013
NHfireLJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
TJ AX-15 is difficult to shift! Replace clutch, clutch & rebuild, or just suck it up! NORCALROOTS TJ Wrangler Technical Forum 38 12-12-2015 09:07 AM
88 5 Speed - Tranny Not Engaging After Clutch install (no clutch need to shift) kgillette YJ Wrangler Technical Forum 12 11-01-2009 12:39 PM
clutch whirrring/squealing noise - but stops when I press on clutch dirtyjpwrangler JK Wrangler Technical Forum 12 09-28-2009 08:55 PM
Question about destroying clutch plate WITH CLUTCH PEDAL DEPRESSED JeffB TJ Wrangler Technical Forum 12 07-20-2009 10:29 AM
great! More AX5 Clutch problems!!!!! hooray for internal clutch slave cylinders! Big-n-Broke-YJ YJ Wrangler Technical Forum 6 08-19-2008 02:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome