getting random sputtering while crusing 4.2 mc2100 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > getting random sputtering while crusing 4.2 mc2100

New jk doors from steinjagerEliminate Hood Flutter!!!Thursday Savings Blast

Reply
Unread 11-01-2012, 08:21 AM   #1
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
getting random sputtering while crusing 4.2 mc2100

specs 4.2l mc2100 msd ignition and msd dizzy

issue: as of late i have been crusing along not accelerating just keeping pace, the jeep will sputter and turn to crap. i have a manual choke set up so i tryed pulling that thinking maybe vacuum leak but its weird i can sit there at idle and have the choke off with no issues rev up no problem and it is not every time i drive. i am starting to think it may be clogged jets? but im not positive. i have also looked for vacuum leaks with it idleing spraying all around the carb with 2+2,along the intake gasket, and the few vacuum lines i have left. any ideas would be great. i may just be getting myself a rebuild kit just to be sure but before i go and spend money i was hoping JF world could keep me from wasting it. thanks!

__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Unread 11-01-2012, 09:55 AM   #2
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,832
filter. Have you changed it?
Jeepsr4me is offline   Reply With Quote Quick reply to this message
Unread 11-01-2012, 11:08 AM   #3
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
Was thinking the that as well. It was changed around may. But I can give it a go. Those are not expensive.
__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Unread 11-01-2012, 11:42 AM   #4
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,832
When you take filter off , take the feed end and stick in a jar or bottle and then get someone to crank engine. let run till it shuts off. See how much fuel you get in the jar. Some pumps just stop working, some just slowly die. This is if you have the manual pump. Electric would be different.
Jeepsr4me is offline   Reply With Quote Quick reply to this message
Unread 11-05-2012, 02:01 PM   #5
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
so here is an update. changed fuel filter no difference. i capped off the fuel return line thinking i may have not been getting enough fuel no difference. so the last things i am thinking would be mechanical fuel pump is going bad slowly, or the jets are clogged at some point in the carb. any other ideas that you guys can think of?
__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Unread 11-05-2012, 02:19 PM   #6
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,832
You try the test I gave you about the fuel? Let us know how much is in bottle when you done and how long engine ran. 10 or more seconds should fill a 20 oz bottle
Jeepsr4me is offline   Reply With Quote Quick reply to this message
Unread 11-05-2012, 02:36 PM   #7
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
i went ahead and did your test as well. in about 5 or so sec i filled a 12 oz cup so that seems to be doing fine. but i just discovered a vac leak from the throttle linkage rod going into the body. it isnt leak when idling but if i give it some gas then i can see some bubbling and i sprayed her down and sure enough it almost killed her. so i think that might be the biggest issue with me crusing seeing that im at partial throttle and i have the stumble. i emailed the guy i got the carb from to see what he suggests but i do not really know of any options for that.
__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Unread 11-05-2012, 03:29 PM   #8
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,832
You can ream out the hole and beat a bushing in there. Some rebuild kits have that.
Jeepsr4me is offline   Reply With Quote Quick reply to this message
Unread 11-06-2012, 09:00 AM   #9
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
i dont exactly have the equipment at my disposal as of now for that. but i will look into that. still waiting to hear back from the guy i got it from.
__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Unread 11-10-2012, 07:22 PM   #10
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
update

so i thought i would give an update. went ahead and got a rebuild kit for it. tore it down dipped the body and put back together. well i found that my one jet happened to be blocked.... completely. not sure what it was but i cleared it out got everything back together (after beating my head into a wall finding the proper gasket for the base of the carb) also found out that the timing was off. so timing sits at 8* and im running at about 21inHg of vacuum. thanks for the help guys!!!
__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Unread 11-10-2012, 07:51 PM   #11
Pamiller
Registered User
 
Join Date: Jul 2012
Posts: 19
I am having the same problem except, it will sputter just a couple time then go back to running normal. When I first got it it would do it only when AC was on, i found a loose ground fixed it and the problem. This just started on my way back from VA 900mile trip. Sometimes it will do it then it will back fire through carb, well more like back poof it's not very loud.

I don't know what carb I have. The PO put a new one on it the day before I bought it, last March. Shortly after I replaced the fuel pump because it was leaking. I replaced the fuel filter but haven't had time to test it. I did find a crack in the intake manifold, I don't have to resources to buy a new one now doin patched it with JB weld. The crack was a very small one. The front and back bolt on the exhaust manifold were loose too I tightened them. I also found a few more wires loose I fixed them.

I don't know what to do next, I drive 70 miles one way to work and this is my dd. I am hoping I have found the problem but I can't duplicate it until I have drive it for a while.
Pamiller is offline   Reply With Quote Quick reply to this message
Unread 02-02-2013, 02:24 PM   #12
lancer27
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2007
Location: maryland
Posts: 403
I just say this reply. Snap a picture of your carb. And we can start from there. I know I have done just about everything to upgrade the stock ignition system. I have an mad ignition, mechanical dizz, mc2100 running 47 jets. I have the stock fuel pump with a pressure regulator. I'm still having some issues but it isn't as bad. I am about to move up to 48 jets and see if that helps but I'm starting to get a little lost. I have also been working over the phone with the manager from New Jersey custom carbs and he has been extremely knowledgable. So lets hope I get the issue gone cuz it's driving me crazy.
__________________
97 tj i6 3.5 RE superflex lift. hp dana 30 4.56 gears ausie up front. dana 44 33spline alloy usa shafts arb rear. tom woods supper short sye and matching cv ds. 35x12.50x15 goodyear MTR's with kevlar. york OBA system. Metal Cloak High Arch tube fenders!(my favorit mod!!!)
lancer27 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.