gas gauge help!!!!!!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > gas gauge help!!!!!!!!

G2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ ChSPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 10-16-2007, 06:11 PM   #1
bill bangler
Registered User
1994 YJ Wrangler 
 
Join Date: Jul 2007
Location: wallingford ct
Posts: 41
gas gauge help!!!!!!!!

my gas gauge is stuck on e and i Know it has gas. What could it be

bill bangler is offline   Reply With Quote
Unread 10-16-2007, 06:28 PM   #2
jeepwrangler123
Registered User
1988 YJ Wrangler 
 
Join Date: Sep 2007
Location: connecticut
Posts: 20
my oil pressure, and voltage gauge do that all the time i just tap on them, or hit them till they feel like working again lol. not really sure what causes it though
jeepwrangler123 is offline   Reply With Quote
Unread 10-17-2007, 05:35 AM   #3
The Rat
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2007
Location: North Dartmouth, MA
Posts: 847
My gas gauge is stuck on whatever I move it to, which is full, that way people think my Jeep runs on magic and never needs refilling.

Actually, I just gave up on fixing it, I fill up every 250-275 miles.
__________________
OH WAIT. WHAT?
The Rat is offline   Reply With Quote
Unread 10-17-2007, 06:35 AM   #4
jaw41272
Registered User
1991 YJ Wrangler 
 
Join Date: Feb 2007
Location: Glendale, NY
Posts: 643
It could be the sending unit in the tank, the guage itself, or just a bad ground
__________________
91 Sahara 4.0l Operation Welcome Home Parade Veh #69
PARADE JEEP MEMBER #1Auto posi-lok equipped, 4" susp. lift
K&N Drop in and loaded with battle scars
www.americaisfull.com
FOR SALE 2005 PT CRUISER CONVERTIBLE
2005 Suzuki DRZ400S For SALE
jaw41272 is offline   Reply With Quote
Unread 10-17-2007, 06:56 AM   #5
PanthrosRevenge
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2007
Location: Thousand Oaks
Posts: 151
Quote:
Originally Posted by jeepwrangler123
my oil pressure, and voltage gauge do that all the time i just tap on them, or hit them till they feel like working again lol. not really sure what causes it though
Watch out for the oil pressure sending unit. Mine ended up blowing out 4/5 of my oil on the freeway.
PanthrosRevenge is offline   Reply With Quote
Unread 10-17-2007, 07:08 AM   #6
EABiker
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2004
Location: Frederick, MD
Posts: 1,676
Does the guage go to empty when the key is turned off?? If not, the guage is bad since it requires a voltage to go to full, and the voltage is not there when the key is off.
EABiker is offline   Reply With Quote
Unread 10-17-2007, 07:29 AM   #7
bill bangler
Registered User
1994 YJ Wrangler 
 
Join Date: Jul 2007
Location: wallingford ct
Posts: 41
any one know where the grounds are for it its a 94 4 cyl and it reads empty all the time
bill bangler is offline   Reply With Quote
Unread 10-17-2007, 08:54 AM   #8
The Rat
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2007
Location: North Dartmouth, MA
Posts: 847
Quote:
Originally Posted by EABiker
Does the guage go to empty when the key is turned off?? If not, the guage is bad since it requires a voltage to go to full, and the voltage is not there when the key is off.
This info isn't accurate, as my gauge always reads full (or wherever I put the needle) even when the Jeep is off.
__________________
OH WAIT. WHAT?
The Rat is offline   Reply With Quote
Unread 10-17-2007, 09:08 AM   #9
whyjay
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2005
Location: Va.
Posts: 402
Mine bounce all over when I hit a bump but it seems to bother the passenger more than me. I just fill up when it starts bouncing oround empty. I also keep an eye on the milage.
whyjay is offline   Reply With Quote
Unread 10-17-2007, 01:20 PM   #10
NJeepyj91
Registered User
1991 YJ Wrangler 
 
Join Date: Feb 2007
Location: NJ
Posts: 512
I don't want to gloat but I am now getting an accurate reading for the 1st time in 15 years. Got rid of that fubarred OEM guage cluster. I am very happy now.
NJeepyj91 is offline   Reply With Quote
Unread 10-17-2007, 05:26 PM   #11
That1guy
Registered User
2007 WK 
 
Join Date: Oct 2007
Location: West Virginia
Posts: 2,415
It could be a bad float, the float might be stuck, bad sending unit, wires might be bad, and/or the gauge is bad.
__________________
I'm forever grateful to Speedycat and RnEmOvr for their generosity
That1guy is offline   Reply With Quote
Unread 10-17-2007, 06:14 PM   #12
NJeepyj91
Registered User
1991 YJ Wrangler 
 
Join Date: Feb 2007
Location: NJ
Posts: 512
I have been putting up with that advice and I respect your post. I changed the pump and the sender. No mean feat with that god awful skid mount.

I cleaned the ribbon so many times.

I got sick of it. No big deal. I replaced all of the gauges.

The only reliable gauges on a yj are the tach and Mph.

Worst design ever...ever.


After replacement. Everything works fine.
NJeepyj91 is offline   Reply With Quote
Unread 10-17-2007, 07:17 PM   #13
Dna5150
Registered User
 
Join Date: Oct 2007
Location: Texas
Posts: 10
Our's does the same thing, but only when we put gas into it when it's nearly empty or is empty. We just swirve back and forth down the road a few times and the floater gets unstuck and starts working again.
Dna5150 is offline   Reply With Quote
Unread 10-17-2007, 08:35 PM   #14
That1guy
Registered User
2007 WK 
 
Join Date: Oct 2007
Location: West Virginia
Posts: 2,415
Quote:
Originally Posted by NJeepyj91
I have been putting up with that advice and I respect your post. I changed the pump and the sender. No mean feat with that god awful skid mount.

I cleaned the ribbon so many times.

I got sick of it. No big deal. I replaced all of the gauges.

The only reliable gauges on a yj are the tach and Mph.

Worst design ever...ever.


After replacement. Everything works fine.

Are you talking about my post? I just listed some possible problems.
__________________
I'm forever grateful to Speedycat and RnEmOvr for their generosity
That1guy is offline   Reply With Quote
Unread 10-18-2007, 12:57 AM   #15
NJeepyj91
Registered User
1991 YJ Wrangler 
 
Join Date: Feb 2007
Location: NJ
Posts: 512
Not specifically. You did list the possible probs and I agree with you.

Been using the trip odo for 15 years. Not a bad solution but my heap is a DD and used under various conditions. I just wanted to solve the issue of no volts, maxxed out oil pressure, iffy temps and no gas indicator.

To tell the truth, I have been on the side of the road twice because I forgot to reset the trip odom. Never again.
NJeepyj91 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.