Funky Electrical Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Funky Electrical Problems

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 04-10-2010, 06:04 PM   #1
Ptr
Senior Member
1992 J-Series Truck 
 
Join Date: Nov 2007
Location: **** you, Texas
Posts: 639
Funky Electrical Problems

My jeep recently (well past 5 months), lost blinkers and wipers. Turns out my wiper motor was fired so I replaced that, but no dice. I just replaced the turn signal harness and turn signal lever. Still I don't have blinkers or wipers. My hazards are working though. All my relays and fuses have been replaced.
Soooo what should I look at replacing next?

Ptr is offline   Reply With Quote
Unread 04-10-2010, 10:49 PM   #2
bharris68
Senior Member
1989 YJ Wrangler 
 
Join Date: Jun 2006
Location: Issaquah, Washington
Posts: 746
On the firewall above the battery you should find test ports which will help you figure out the voltages going to, or from, various points on the vehicle. With the Factory Service Manual you'll be able to determine with a little more accuracy what is going wrong.

What goodies do you have hooked into the harness? I'm asking to figure out what may have severed it at some point? Also - when you had the windshield down and the motor exposed, did you check to see if you were getting voltage from the switch?

Voltage could be a problem if the ground was not correctly attached in the steering column. Check both sides of the harness there on the column for correct ground and power.
bharris68 is offline   Reply With Quote
Unread 04-11-2010, 10:23 AM   #3
Ptr
Senior Member
1992 J-Series Truck 
 
Join Date: Nov 2007
Location: **** you, Texas
Posts: 639
I don't have a test port above my battery..
THe harness that I replaced was this:
I did not try testing to see if there is voltage going to the motor yet.
Where is the ground on the steering column located?
Ptr is offline   Reply With Quote
Unread 04-11-2010, 10:31 AM   #4
bharris68
Senior Member
1989 YJ Wrangler 
 
Join Date: Jun 2006
Location: Issaquah, Washington
Posts: 746
Gotcha - you can see the cancelling cams there in the picture and the ground I believe is next to the horn button for the horn. Does your horn work? If your hazards don't work, and your turn signals don't work my thinking is that the electrical on the harness end is not connected or has broken?
bharris68 is offline   Reply With Quote
Unread 04-11-2010, 10:35 AM   #5
Ptr
Senior Member
1992 J-Series Truck 
 
Join Date: Nov 2007
Location: **** you, Texas
Posts: 639
Yes, my horn does work. Along with the hazards too.
All the connections are put together correctly too.
Ptr is offline   Reply With Quote
Unread 04-11-2010, 10:55 AM   #6
Ptr
Senior Member
1992 J-Series Truck 
 
Join Date: Nov 2007
Location: **** you, Texas
Posts: 639
In addition to the wipers and blinkers not working, my cigarette lighter doesn't work. Could this be part of the mystery or something else?
Ptr is offline   Reply With Quote
Unread 04-11-2010, 11:46 AM   #7
dodger889
Registered User
1989 YJ Wrangler 
 
Join Date: Jan 2009
Location: mi
Posts: 4,162
Check you fuses under the dash.
__________________
A 89 yj with a 4.0 aw4 sye out of an 92xj. Now the hard part is done time to get it up in the air just a bit. Working on 8.8 with 3.73 and lsd for the rear. and new D30 hp with 3.73 .
For those who have not figured this out I'm old school but can handle the new too.
Quote:
Originally Posted by bigsquat View Post
im just cheap, and cheap makes you creative.
dodger889 is offline   Reply With Quote
Unread 04-11-2010, 11:53 AM   #8
Fhajad
Registered User
1993 YJ Wrangler 
 
Join Date: Jun 2009
Location: Greenfield, Indiana
Posts: 1,934
Have you tried flipping around the hazard/flasher unit to see if the flasher unit is dead?
Fhajad is offline   Reply With Quote
Unread 04-11-2010, 12:02 PM   #9
Ptr
Senior Member
1992 J-Series Truck 
 
Join Date: Nov 2007
Location: **** you, Texas
Posts: 639
Fuses are good and flasher units too. I even switched them around.
Ptr is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.