Fuel System Problems???? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Fuel System Problems????

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 07-02-2001, 02:42 AM   #1
bigjeep39
Registered User
2004 WJ 
 
Join Date: Apr 2001
Location: Albuquerque New Mexico
Posts: 815
Fuel System Problems????

Ok, i have an 89 YJ with a 258 6cyl 4.2l. It has a mechanical fuel pump located on the engine block. It started with my Jeep running fine then the Jeep shutterd and stahled and would not start. My dad and I took the fuel hose off and we tried turning the Jeep over and little drops of gas came dribbling out the hose. In a normal Jeep it would squirt out in a stream. The problem is, i thought it was fuel pump. I replaced the $20 dollar pump and a $4 dollar fuel filter at the same time. I thought our worries were over. It didn't start so i decided to fill the floatbowls on the carburator and it fired up and worked great. I drove it for 15 minutes, parked it, went inside for about an hour, left the house again and it fired up i pulled out of the driveway and it died. Well, there it stands, i nor my dad is a jeep master so we think it is somewhere along the fuel lines, we want to drop the gas tank and blow out all the hoses, will this work, is it the cam not hitting the pump, what is it? PLEASE HELP, i need this Jeep to run, i would appreciate it a lot, thank you.

__________________
2012 Jeep Liberty
2006 Toyota Tacoma (Selling for a Rubicon)
bigjeep39 is offline   Reply With Quote
Unread 07-02-2001, 10:45 AM   #2
JoeServo
Registered User
 
Join Date: May 2001
Location: Auburn Hills, MI
Posts: 11
You touched on the two possible problems. Either the eccentric loosened off the dowel or the lines/pickup are clogged. try removing the inlet of the pump and place it in a fuel container. then check the flow through the outlet.
__________________
87 YJ with the ugliest top you have ever seen
JoeServo is offline   Reply With Quote
Unread 07-02-2001, 02:29 PM   #3
bigjeep39
Registered User
2004 WJ 
 
Join Date: Apr 2001
Location: Albuquerque New Mexico
Posts: 815
Hey servo the pump works, that is all good, i can get it to run, i think it might be somewhere inside the fuel system near the tank, is there any screens along the way that could possibly be clogged. And servo what did you mean about the eccentric
__________________
2012 Jeep Liberty
2006 Toyota Tacoma (Selling for a Rubicon)
bigjeep39 is offline   Reply With Quote
Unread 07-04-2001, 02:10 PM   #4
lostboy
Registered User
 
Join Date: May 2001
Location: NY
Posts: 533
Hey BigJeep, Look for a bad return line that goes to the tank.It could be crimped or clogged. It would cause a vacuum in the fuel delivery system that the pump can't overcome. Good Luck
__________________
89 yj w/ mopar mpi and 4.0 head.94 ax-15 tranny and t-case, more mods comin.
lostboy is offline   Reply With Quote
Unread 07-04-2001, 05:12 PM   #5
bigjeep39
Registered User
2004 WJ 
 
Join Date: Apr 2001
Location: Albuquerque New Mexico
Posts: 815
You are absolutely correct, i appreciate it and if it happens again i might try the charcoal vaccum canister and see if thats crimped, i appreciate it my line was crimped and i bought a new one, thanks.
__________________
2012 Jeep Liberty
2006 Toyota Tacoma (Selling for a Rubicon)
bigjeep39 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.