Fuel pump issues - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 07-03-2013, 08:03 PM Thread Starter
rusty94yj
Registered User
 
Join Date: Jul 2013
Posts: 10
Fuel pump issues

Hey I'm new to the forum and new to jeeps. Just picked up a 94 wrangler that's been sitting for 3 years bc "the fuel pump went out". Turns out the fuel pump works fine. when I remove the fuel pump relay and use a jumper lead I can send power to the pump and it runs fine. All fuses are good, all relays are good. Does anyone know of any sensors in the circuit the fuel pump may be reliant on to work properly? Or has anyone run into this before? Thanks for any help. Ps the battery is brand new and when I turn the key the starter cranks just fine, but the fuel pump never primes or pumps when I turn the key to ON.

rusty94yj is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-03-2013, 10:46 PM
Strugoi
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2009
Location: Marana
Posts: 3
What was the jeep doing that made you think of the Fuel Pump?

Hey Rusty,

How was the jeep acting when you discovered that it was fuel pump relay?
Was it sputtering and backfiring? How did you test the fuel pump? Do you have pics? Sorry to be a pain, but I just posted a question on my jeep and I suspect that the pump may be related to my problem.
Strugoi is offline  
post #3 of 7 Old 07-04-2013, 05:24 AM
kloppk
Registered User
1992 YJ Wrangler 
 
Join Date: Oct 2006
Posts: 2,751
Rusty,

Do you get any dashboard idiot lights coming on when you turn the key to the RUN position?
If not then the PCM may be bad or not getting power.

Baystate Jeepers
Deep Woods Extreme
New England 4 Wheelers
kloppk is offline  
post #4 of 7 Old 07-04-2013, 11:07 AM
Strugoi
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2009
Location: Marana
Posts: 3
I do now that I changed out the oxygen sensor. I have yet to put a code reader on it because it usually resets once I turn off the jeep. I posted yesterday (7/3/13) about the 94 YJ that is backfiring and sputtering, the full details are in that post.
Strugoi is offline  
post #5 of 7 Old 07-05-2013, 02:07 PM Thread Starter
rusty94yj
Registered User
 
Join Date: Jul 2013
Posts: 10
The jeep hasn't run since I picked it up so no symptoms to report. http://www.jeepforum.com/forum/f12/f...-help-1396299/
I followed directions in that thread to jumper the relay and test the pump
rusty94yj is offline  
post #6 of 7 Old 07-05-2013, 02:10 PM Thread Starter
rusty94yj
Registered User
 
Join Date: Jul 2013
Posts: 10
Kloppk,

No idiot lights when the key is on, just break and seatbelt. Thanks for the tip on the PCM ill look into and I guess start doing voltage drops on the circuit? Ill let u know if I stumble into a solution.
rusty94yj is offline  
post #7 of 7 Old 07-05-2013, 04:42 PM Thread Starter
rusty94yj
Registered User
 
Join Date: Jul 2013
Posts: 10
Update: I back probed the fuel pump side of fuel pump connector. Volts test with key on provided basically 0 V. I disconnected fuel pump from wire harness and did a continuity test on the plug coming from wire harness. With negative lead connected to the frame I use the positive lead to test the coupling and found continuity on 2 of 3 pins. Green w/ black wire has continuity, blue wire had continuity and black w red wire does not. Double rainbow size what does this all mean? If anything?
rusty94yj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome