Frustrating to the point I just want to shoot my jeep!!!! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 09-01-2011, 06:26 PM Thread Starter
headhunter47
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2011
Location: headhunter47
Posts: 7
Frustrating to the point I just want to shoot my jeep!!!!

Ok, so, where to begin?

I bought my jeep from this guy and after having it for three months I have came to the realization that the moron jacked a lot of crap up. So here is my dilema. I have searched all over this forum and many others and yet I am still having issues.

I have an MC 2100 carb with an HEI distibutor.

The first thing that happend was that she started missing really bad at idle and while under load and had a constant backfire. Come to find out the carb base was craked so I ordered a MC 2100 from the dude in CO. That helped a lot but it still misses and backfires, not as often, but still does. I started to check for vacuum leaks and boy did I find a ton. Changed all the vacuum lines (there was only four, one for the PCV valve, one for the vacuum advance, one for the front axle, and one for the brake thingy). This helped a little more but she was still sputtering and backfiring every know and then. So upon spraying the crap out of the enigne bay with carb cleaner to see if there was more leaks, low and behold my intake/exhaust gasket was bad. So, this morning i changed those. Runs a little better but still sputters and backfires. I have changed spark plugs and the distributor is the CRT performance one. Timing is initially set at 12* BTDC.

So, my issue is why the hell is it still sputtering and backfiring when I know for a fact she has no leaks, carb is set up right, and the timing is good?

I did a vacuum check on the manifold and she fluctuates by 1Hg from 21Hg. I hear an audible pop from the exhaust while at idle and the jeep lurches while driving when it sputters. Any help would be greatly appreciated as I am at wits end with this jeep. I am about to put a bullet in her and just walk to work. Thanks.

headhunter47 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-01-2011, 06:43 PM
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
Sounds like its running way rich. Not sure about the vac fluctuation since you said you checked it all. I'm a chevy guy from way back before I got into jeeps, and I always used the HEI with the vacuum hooked directly to the manifold. I'm not all familiar with carbed jeeps tho (mine is injected), but lots of guys here have setup just like yours. Stick around for a bit, one of them will be along eventually.

.
oldtime_ironman is offline  
post #3 of 3 Old 09-01-2011, 07:16 PM
rustybeater
Registered User
1991 YJ Wrangler 
 
Join Date: May 2009
Location: lexington park
Posts: 176
It has been a while since i have messed with a HEI but it does sound like a timing issue maybe try to replace the ignition control modulator on the distribitor. once you take the cap off it is where the wires plug in (not your spark plug wires but your power wire going in to it) on the base of it. Worth a shot.
rustybeater is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2 point or 3 point seat belts?????? Brock1 YJ Wrangler Technical Forum 23 04-09-2010 05:33 AM
Frustrating!!! 94yjssirok Wrangler General Discussion 3 08-22-2008 11:20 AM
Hottest point under the jeep ArrizX TJ Wrangler Technical Forum 5 08-18-2008 08:26 AM
So frustrating sequel YJ Wrangler Technical Forum 2 10-10-2006 12:38 AM
My Jeep photo shoot Germ TJ Wrangler Technical Forum 9 07-30-2003 10:23 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome