Frustrating to the point I just want to shoot my jeep!!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Frustrating to the point I just want to shoot my jeep!!!!

Dual Color LED Light Bars White/AmberTJ 5.25" Speaker Adapters - NalinMFGAlloy USA Still Available

Reply
Unread 09-01-2011, 06:26 PM   #1
headhunter47
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2011
Location: headhunter47, MO
Posts: 7
Frustrating to the point I just want to shoot my jeep!!!!

Ok, so, where to begin?

I bought my jeep from this guy and after having it for three months I have came to the realization that the moron jacked a lot of crap up. So here is my dilema. I have searched all over this forum and many others and yet I am still having issues.

I have an MC 2100 carb with an HEI distibutor.

The first thing that happend was that she started missing really bad at idle and while under load and had a constant backfire. Come to find out the carb base was craked so I ordered a MC 2100 from the dude in CO. That helped a lot but it still misses and backfires, not as often, but still does. I started to check for vacuum leaks and boy did I find a ton. Changed all the vacuum lines (there was only four, one for the PCV valve, one for the vacuum advance, one for the front axle, and one for the brake thingy). This helped a little more but she was still sputtering and backfiring every know and then. So upon spraying the crap out of the enigne bay with carb cleaner to see if there was more leaks, low and behold my intake/exhaust gasket was bad. So, this morning i changed those. Runs a little better but still sputters and backfires. I have changed spark plugs and the distributor is the CRT performance one. Timing is initially set at 12* BTDC.

So, my issue is why the hell is it still sputtering and backfiring when I know for a fact she has no leaks, carb is set up right, and the timing is good?

I did a vacuum check on the manifold and she fluctuates by 1Hg from 21Hg. I hear an audible pop from the exhaust while at idle and the jeep lurches while driving when it sputters. Any help would be greatly appreciated as I am at wits end with this jeep. I am about to put a bullet in her and just walk to work. Thanks.

headhunter47 is offline   Reply With Quote
Unread 09-01-2011, 06:43 PM   #2
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls, NY
Posts: 2,540
Sounds like its running way rich. Not sure about the vac fluctuation since you said you checked it all. I'm a chevy guy from way back before I got into jeeps, and I always used the HEI with the vacuum hooked directly to the manifold. I'm not all familiar with carbed jeeps tho (mine is injected), but lots of guys here have setup just like yours. Stick around for a bit, one of them will be along eventually.

.
oldtime_ironman is offline   Reply With Quote
Unread 09-01-2011, 07:16 PM   #3
rustybeater
Registered User
1991 YJ Wrangler 
 
Join Date: May 2009
Location: lexington park, Maryland
Posts: 142
It has been a while since i have messed with a HEI but it does sound like a timing issue maybe try to replace the ignition control modulator on the distribitor. once you take the cap off it is where the wires plug in (not your spark plug wires but your power wire going in to it) on the base of it. Worth a shot.
rustybeater is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.