Epic Ignition Battle (replaced everything but the ignition switch!) - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Epic Ignition Battle (replaced everything but the ignition switch!)

Jeep Grand Cherokee Mirror - Side ViewJeep Grand Cherokee Headlight AssembliesThe Retrofit Source / JW Speaker LED Headlight GROUP BUY!

Reply
Unread 08-21-2009, 08:17 PM   #1
thechadwick
Registered User
2000 WJ 
 
Join Date: Mar 2008
Location: FT Benning, Georgia
Posts: 6
Epic Ignition Battle (replaced everything but the ignition switch!)

Living the dream here in Sunny Phoenix AZ when midway through a rain storm I lost the ability to start my car without parking on a hill. Lights, Gauges, Stereo all fine but no activity when I go to turn the key to start. Found what appeared to be the source of the problem (Pos lead to starter had contacted the solenoid ground and shorted...) 1 refurbished starter later still no dice. Replaced the leads from the battery which had tested good thinking it was a bad ground or something to no avail. Take the battery in again and sure enough its bad. New battery plugged and ready still no dice. So now I'm thinking the rain and short must have catastrophically damaged the starter relay right? Nope, no go. Tested continuity on all the maxi fuses, all good but replaced the ign one for good measure. So now I'm down to behind the firewall I'm thinking is where my continuity problem lies, removed the ign switch and it doesn't smell burnt but looks different than the one specified in the haynes. Run down to the auto shop store and the one they have looks like the one in the picture but after opening and inspecting every single box of ign switches(thx checker cashier) I left empty handed and broken hearted that I'll ever start my Jeep by key again... I'm working on a 1994 YJ 2.5l with a manual trans. hoping somebody out there might know the magic words to bring her back to life. here's a couple pics of what I'm talking about. Thanks guys -Chad
-492D CA Bn, Phoenix AZ


thechadwick is offline   Reply With Quote
Unread 08-26-2009, 09:51 PM   #2
thechadwick
Registered User
2000 WJ 
 
Join Date: Mar 2008
Location: FT Benning, Georgia
Posts: 6
Two weeks now, still no luck finding out what type of ignition switch I've even got on my steering column. Looks like I'm not going to get much love from the dealership regarding a 15 year old vehicle.. sure happy to sell me a new one though (eyes roll)... Anyone have an idea? Maybe (please Lord) a guess at a part number?
thechadwick is offline   Reply With Quote
Unread 08-26-2009, 09:56 PM   #3
wheresthebfh
Registered User
1987 YJ Wrangler 
 
Join Date: May 2009
Location: seattle
Posts: 68
if you does it turn over but not start or just nothing? Just asking cause theres not a lot of hills in phoenix. Have you tried pull a part or a craigslist wrangler being parted out?
__________________
Milk it does a body good........
wheresthebfh is offline   Reply With Quote
Unread 08-26-2009, 10:06 PM   #4
thechadwick
Registered User
2000 WJ 
 
Join Date: Mar 2008
Location: FT Benning, Georgia
Posts: 6
"theres not a lot of hills in phoenix." Ha you aren't kidding, kind of a pain actually. Haven't had time to run to a pick and pull, but that's a great idea. Know any ones worth recommending? Recently moved to mesa from Ft. Jackson, SC and I'm not real familiar with the area... Anyway, it'll run fine but when I turn the key I either get a solid clunk or solenoid chatter. tested the solenoid and it's ok by the Haynes electrical manual. With the thing driving though the gauges (speedo and tach) bounce around like somethings shorted. other than that all's normal. Thanks for the reply man -Chad
thechadwick is offline   Reply With Quote
Unread 08-26-2009, 10:40 PM   #5
thechadwick
Registered User
2000 WJ 
 
Join Date: Mar 2008
Location: FT Benning, Georgia
Posts: 6
wow, Major Major moment... Pictured item = headlamp dimmer switch... ≠ign switch. very embarrassed. Relieved to know I don't have a one off steering column
thechadwick is offline   Reply With Quote
Unread 08-27-2009, 02:46 AM   #6
timatoe
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2006
Location: Grass Valley California
Posts: 13,671
The actual ignition switch is on top of the column behing the dash held on there with a couple of 7mm bolts. There's a rod that runs down the column into the switch, that's activated by the key switch part. Make sure you get that rod back in the right place when you put the new switch on there.
__________________
Quote:
Originally Posted by George Orwell
We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm.
timatoe is offline   Reply With Quote
Unread 08-27-2009, 03:24 AM   #7
HHippo
Registered User
1995 YJ Wrangler 
 
Join Date: Jun 2009
Location: Mesa, AZ
Posts: 95
In Mesa there is a big "Pick-a-part" on Extension just south of Main. Several other smaller ones in the same hood.
The switch on the column is a garden variety GM type switch, but if the starter makes a clunk and the solenoid chatters when you turn the key to start, odds are the switch is fine. Should have a starter relay if it is like mine. Check that there is no voltage drop across the red and brown wires at the starter relay when attempting to crank (the yellow comes from the crank position at the switch and if you have battery voltage there when cranking the switch is fine). Be careful when checking this and make sure the vehicle is in neutral at all times as it can accidentally crank with the key off if you touch the red and brown wires.
Check battery voltage while charging and while attempting to crank, and do a voltage drop test on the pos and neg battery cables. If all that checks to spec it probably is in the starter.
HHippo is offline   Reply With Quote
Unread 08-27-2009, 06:03 AM   #8
drunkencitywork
Registered User
1995 YJ Wrangler 
 
Join Date: Mar 2009
Location: southside chicago
Posts: 137
sounds like what i went thru just to find out it my computer was bad
__________________
95yj2.5auto-4"sua-305/70bfg mt on rubi's-4.0tb-frnt tube fenders-frnt&rear fabbed bumps w tire swing-8.8lsd disc-shortened xj soon cage,rockers,diff covers
drunkencitywork is offline   Reply With Quote
Unread 08-27-2009, 06:14 AM   #9
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,764
I got to ask. Did you try and jumper the starter relay. It seems you went strait for the switch and the relay is usually the weak point. I am a few minutes late with posting today. everyone is bearting me to the punch. HHippo did a great job of explaing it.
Que89YJ is offline   Reply With Quote
Unread 08-27-2009, 08:26 PM   #10
Smash209
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2001
Location: CT
Posts: 333
Check to make sure the wire that goes from ign switch to starter solinoid is not intermittent. I had to run a new wire end to end as it has a few splices (threw firewall bulkhead connector etc.) which were causing an intermittent problem.

You could try just jumpering the starter terminals when it wont start to diagnose the problem as Que89YJ suggested.
__________________
~~~ \\ // ~~~ ,,,,,, ~~~~~~~~~~
~~~~ //~~~~~|| ~~~~~~~~~~~~
~~~~//~~~~~ ||~~~~~~~~~~~~
~~~~~~~~~ \\// ~~~~~~~~~~~~
Smash209 is offline   Reply With Quote
Unread 08-27-2009, 11:02 PM   #11
WCoon
Registered User
1993 YJ Wrangler 
 
Join Date: Nov 2003
Location: Oklahoma City, OK
Posts: 570
Also try running a second wire from the pos terminal to the pos on the starter. I had some starting issues and I ended up running a second, 4ga wire to the starter since the original one wasn't flowing enough current. You could also check it with some jumper cables to see if it does anything for a quick check. Let us know what you find.
WCoon is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.