Engine idles at 3k - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 02-13-2012, 06:58 PM Thread Starter
94chb
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2009
Location: Whitwell
Posts: 1,936
Engine idles at 3k

hey guys, my buddy has a 95 wrangler 2.5 the jeep ran great but the water pump was bad so i replaced it for him now when you crank the jeep it stays at 3k and wont idle down. ive looked for vacuum leaks and didnt find anything. idk what the hell the problem is . maybe you can help.

94chb is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 02-13-2012, 07:03 PM
dilligaf69
Registered User
1998 ZJ 
 
Join Date: Nov 2008
Location: Tucson
Posts: 88
Make sure that you didn't by some chance move the throttle cable, check to make sure the butterfly on the throttle body is closed. I know you didn't have to mess with it while changing the water pump, but there is always that chance.

Dent, what dent.... That's not a dent.... that's a good memory.
dilligaf69 is offline  
post #3 of 8 Old 02-13-2012, 07:04 PM Thread Starter
94chb
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2009
Location: Whitwell
Posts: 1,936
i checked i also choked it with my hand and it still didnt idle down.
94chb is offline  
post #4 of 8 Old 02-13-2012, 07:30 PM
pasinbuy
Registered User
1994 YJ Wrangler 
 
Join Date: Feb 2007
Location: florida
Posts: 3,902
First try cleaning the IAC it is on the pass side of the throttle body. If that does not work, go buy a new one.
pasinbuy is offline  
post #5 of 8 Old 02-13-2012, 07:31 PM
dilligaf69
Registered User
1998 ZJ 
 
Join Date: Nov 2008
Location: Tucson
Posts: 88
double check all of you manifold vacuum lines to make sure they didn't get cracked. only other reason I can think of is for some reason the idle speed control motor has gotten stuck open or has gotten disconnected. That shouldn't have been affected by changing the water pump though.

Dent, what dent.... That's not a dent.... that's a good memory.
dilligaf69 is offline  
post #6 of 8 Old 02-13-2012, 07:34 PM Thread Starter
94chb
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2009
Location: Whitwell
Posts: 1,936
but even with me sticking hand hand over the TB and choking it should have idled it down. ive checked and checked and checked. ill wait til tmw to look again. im stumped.
94chb is offline  
post #7 of 8 Old 02-18-2012, 08:30 PM Thread Starter
94chb
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2009
Location: Whitwell
Posts: 1,936
Fixed the Problem. Bad intake manifold gasket. replaced it and everythign is perfect.
94chb is offline  
post #8 of 8 Old 02-21-2012, 08:00 PM
dilligaf69
Registered User
1998 ZJ 
 
Join Date: Nov 2008
Location: Tucson
Posts: 88
good to hear you got it fixed. That would have been my next guess if it wasn't the IAC.

Dent, what dent.... That's not a dent.... that's a good memory.
dilligaf69 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
95 yj idles rough after right engine bracket broke ! IvansRed95YJ YJ Wrangler Technical Forum 7 10-29-2011 11:57 AM
90 YJ idles at 3k-3.5k! lexinator02 YJ Wrangler Technical Forum 6 04-07-2010 12:53 PM
Rough/low idle once engine warms up...idles fine when cold sb127 TJ Wrangler Technical Forum 14 11-14-2008 11:06 AM
4.0 idles rough.. have 6 engine codes.. mikevsgeek TJ Wrangler Technical Forum 1 09-17-2007 05:27 PM
Idles at 3k? bmcwbc TJ Wrangler Technical Forum 9 05-26-2006 11:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome