Engine cutting out above 40mph after 15min - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Engine cutting out above 40mph after 15min

Premium LED Lighting by VISION X, Proudly sold at ROCKRIDGZONE 4.25" combo lift for TJ available at Rockridge4wSPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!

Reply
Unread 04-03-2010, 11:09 AM   #1
jaminb
Registered User
1999 TJ Wrangler 
 
Join Date: Sep 2007
Location: Canton, MI
Posts: 818
Engine cutting out above 40mph after 15min

So yesterday when the temp here in michigan started going up i started having issues with my jeep cutting out above about 40mph. It will rev to the moon in park, and accelerate just like normal even if its foot to the floor but as soon as i hit about 40mph it cuts out.

I have a weber 38 thats still running a little rich and the jeep would do this before if it sat at idle to long almost like it was fouling out the plugs..

What leads me to think it has something to do with the temp is that i drove it last night for about 10-15 min and nothing happend (it was about 60* out)

Any ideas?


edit: also forgot to say the the starter grinds if/when the jeep stalls out do to the issue thats happening, it almost seems like there is too much compression in the engine.
Oh and it is nuttered.


Last edited by jaminb; 04-03-2010 at 11:39 AM..
jaminb is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.