Electrical Issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Electrical Issues

End of Summer Sale, 20% OFF!2007 - 2011 Jeep JK Long Arm Lift KitsIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-23-2013, 08:17 PM   #1
jdbillin
Registered User
 
Join Date: Jun 2013
Location: Marysville, Ohio
Posts: 3
Electrical Issues

Hi guys I have a '89 wrangler it was my grandpas and when we got it a few years ago it ran fine and I know he only drove it a few times its just been sitting for the past few years.

So I have attempted to get it running and of course haven't had any luck the first problem I had was the fuel pump wasn't kicking on and after I messed around with it for a little bit I figured out the relay by the battery was really corroded so I put spade connectors on it and now if I ground out the trigger wire on it the pump will run so that kind of solved that problem.

But now the throttle body won't inject any fuel. I think its a issue with the ECU I imagine that it changes the voltage to vary the amount of fuel and probably has something to do with the fuel pump still not kicking on.

I'm just not sure what else to check or what could be causing this I checked all the basics I know that one of the fuses was blown I can't remember what it was labeled as something ignition but it still has spark and would run of ether. I replaced the fuse and it hasn't blown again.

I just need some ideas or some more things to check any help would be greatly appreciated

Thank you
Jordan

jdbillin is offline   Reply With Quote
Unread 06-27-2013, 02:10 PM   #2
jdbillin
Registered User
 
Join Date: Jun 2013
Location: Marysville, Ohio
Posts: 3
Anyone have any ideas?

Thanks
Jordan
jdbillin is offline   Reply With Quote
Unread 06-27-2013, 03:21 PM   #3
mike_breaker_5
Web Wheeler
 
mike_breaker_5's Avatar
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: emporium,, pennsylvania
Posts: 2,956
89's were carbbed, if you actually do have an 89 with tb injection then you have a jeep that has been modified.

check into this. my first assumption is CPS if the fuel pump wouldn't cycle when the key is turned on.

we will need to know a little more for certain exactly what is under the hood.
__________________
Ratmonkey donation page. all proceeds will go to his family.
http://www.youcaring.com/memorial-fu..._source=widget


it's not much to look at... but it's mine.
5.2lswap, metalcloaks, bedliner, tucked belly, d60's, soon to be nv4500 and d300.
http://www.jeepforum.com/forum/f22/m...r-junk-990191/
mike_breaker_5 is offline   Reply With Quote
Unread 06-27-2013, 03:23 PM   #4
mike_breaker_5
Web Wheeler
 
mike_breaker_5's Avatar
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: emporium,, pennsylvania
Posts: 2,956
unless it's a 4cyl. i forgot about those having tb injection.
__________________
Ratmonkey donation page. all proceeds will go to his family.
http://www.youcaring.com/memorial-fu..._source=widget


it's not much to look at... but it's mine.
5.2lswap, metalcloaks, bedliner, tucked belly, d60's, soon to be nv4500 and d300.
http://www.jeepforum.com/forum/f22/m...r-junk-990191/
mike_breaker_5 is offline   Reply With Quote
Unread 06-27-2013, 06:33 PM   #5
jokerchief462
Wild Wheeler
 
jokerchief462's Avatar
1989 YJ Wrangler 
 
Join Date: Nov 2010
Location: Sin City, Nevada
Posts: 2,847
I answered on WF
__________________
89YJ 2.5L TBI, AX-5, NP231 SYE, Ford 8.8, Yukon Grizzly, Tom Woods Shaft, 33" BFG T/As, 4" lift, Warn VR10000s.

AF Jeep Club Tail #184
jokerchief462 is offline   Reply With Quote
Unread 06-29-2013, 10:55 AM   #6
jdbillin
Registered User
 
Join Date: Jun 2013
Location: Marysville, Ohio
Posts: 3
Quote:
Originally Posted by mike_breaker_5 View Post
unless it's a 4cyl. i forgot about those having tb injection.
Yes its a 4cyl
jdbillin is offline   Reply With Quote
Unread 06-29-2013, 11:27 AM   #7
pete1991YJ
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2012
Location: Niagara Falls, NY
Posts: 1,628
If the relay was that corroded, then chances are the grounds are really shot. I would take the time to disconnect and clean every connection I could find, and use dielectric grease when they go back together. The injector in particular has its own ground but I forget the details -- theres a few other guys around here with the 89 4-banger, one of them should be along eventually.

It maybe one of those deals where more than one thing feeds off that relay, so it needs that in order to fire.

EDIT to add make DARN sure the computer is grounded, its housing is grounded, and the ICM (ignition control module, if any) is grounded and has clean tight connections. There should be a body ground strap in the firewall and an engine ground strap near the back of the head -- what kind of shape are they in?
__________________
***--- Wrecking Crew member ---***
"I've prolly been around longer than you think"
pete1991YJ is offline   Reply With Quote
Unread 06-29-2013, 11:29 AM   #8
mike_breaker_5
Web Wheeler
 
mike_breaker_5's Avatar
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: emporium,, pennsylvania
Posts: 2,956
Quote:
Originally Posted by jdbillin View Post
Yes its a 4cyl
you really should fill out your profile so we can better know what vehicle we are talking about for future reference.
__________________
Ratmonkey donation page. all proceeds will go to his family.
http://www.youcaring.com/memorial-fu..._source=widget


it's not much to look at... but it's mine.
5.2lswap, metalcloaks, bedliner, tucked belly, d60's, soon to be nv4500 and d300.
http://www.jeepforum.com/forum/f22/m...r-junk-990191/
mike_breaker_5 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.