ECM issues after "brain surgery" - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > ECM issues after "brain surgery"

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank Skid

Reply
Unread 10-02-2013, 02:35 PM   #1
caseybam1128
Registered User
1998 TJ Wrangler 
 
Join Date: Oct 2012
Location: Waterford, PA
Posts: 13
ECM issues after "brain surgery"

so once again I find myself at square one. My Jeep (94 Wrangler 2.5L 4cyl) was giving me starting issues which i previously posted on here: http://www.jeepforum.com/forum/f12/start-probs-1568880/ , and with the help of others concluded it was the capacitors in my ECM. I followed the careful write-up Crash Course In Brain Surgery Replacing Capacitors On ECU, listed here: http://www.jeepforum.com/forum/f12/c...rs-ecu-492597/ . After replacing the caps, I plugged in the ECM and presto! she fired right up. I checked my codes and get 12, 33, 41, 51, 23, 55 . She ran good for about 2 weeks and then suddenly when driving home from work, my jeep shutdown while driving, pretty scary to say the least. I got it home and after sitting, it would start up, and immediately die. If I drove it, I would need to constantly hold my foot on the gas pedal or it would die on me again. I cleaned inside the air intake and it would run fine, until it started to warm up. After warming up it would, at first, act like it was being choked for air. the RPM would drop very low, and then spike back up for a split second. Then eventually, it would just stall out. I took off the O2 sensor to wire brush it, and replaced the capacitors once more in the ECM now it won't start at all! The check engine light doesn't turn on while in run position and cant pull any codes now. Occasionally if I crank it, the check engine light will come on, but still no start. Could I have ruined my ECM? or could this be something else?

caseybam1128 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.