Driving me nuts!!! Has plenty of power - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Driving me nuts!!! Has plenty of power

NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineYear End Clearance Sale! Save 20%

Reply
Unread 08-19-2011, 11:33 PM   #1
wildbadbill
Registered User
1994 YJ Wrangler 
 
Join Date: Aug 2008
Location: houston
Posts: 127
Driving me nuts!!! Has plenty of power

and idles ok,but with the throttle just barelly open (about 14-1500 rpm) it surges BAD!
Changed IAC and MAP,no change.Thought of fuel pump,but it would manifest itself at higher speeds/loads.Spark plugs would also act up through entire range I guess.When it surges like that (light throttle) and take foot of gas,it may occasionally die...wtf?

wildbadbill is offline   Reply With Quote Quick reply to this message
Unread 08-19-2011, 11:43 PM   #2
Xpress
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2010
Location: The Great Big Box, California
Posts: 5,811
Cap/rotor change? Maybe fuel filter?

Also check all of your vacuum lines. Sounds like you might also have a leak. Poke around with some starter fluid.
__________________
[URL="http://www.jeepforum.com/forum/f12/another-5-2l-yj-thread-1503048/"]My 5.2L Build thread[/URL]

-1989 Jeep Wrangler 2.5L, soon to be 5.2L
-1996 Jeep Grand Cherokar 5.2L, donor and rainy day driver
-2004 Kawasaki KLR650 sunny day driver
[QUOTE=mudsweatNgearz;21162729]Leave em off and weld an I beam on. Bumperetts just scream homo.[/QUOTE]
"A well regulated Militia, being necessary to the security of a free State, the [B][I]RIGHT[/I][/B] of the people to keep and bear Arms, [B][I]SHALL NOT BE INFRINGED[/I][/B]."
Xpress is offline   Reply With Quote Quick reply to this message
Unread 08-20-2011, 12:22 AM   #3
wildbadbill
Registered User
1994 YJ Wrangler 
 
Join Date: Aug 2008
Location: houston
Posts: 127
will check vacuum again,fuel filter is fairly new,as is the cup...thanks
wildbadbill is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.