dashboard gauges not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > dashboard gauges not working

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 08-07-2011, 11:13 PM   #1
shu2kill
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2009
Location: chihuahua
Posts: 267
dashboard gauges not working

hey. i just came back from a semi-light wheeling trip. i broke 2 shock absorber bases, but i will weld them back tomorrow.

the problem is that, my gauges arent working. i dont have the rpm meter, speed meter, nor any of the other gauges. the fuel gauge went all the way right, to the FULL position, and the battery, temp, and oil, went to the left.... i didnt notice when it happened, so i dont know what could be wrong... im thinking a broken/loose cable, but, where should i start looking?? i dont have any gauge right now....

my jeep is a 92 YJ, 6 cil, if that makes a difference...

thanx!!

shu2kill is offline   Reply With Quote Quick reply to this message
Unread 08-08-2011, 11:05 AM   #2
shu2kill
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2009
Location: chihuahua
Posts: 267
anyone??
shu2kill is offline   Reply With Quote Quick reply to this message
Unread 02-16-2014, 12:08 AM   #3
matrix311
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2011
Location: Tempe, AZ
Posts: 273
Did you figure this problem out? My YJ started doing this same thing today. Please post up the fix if you figured it out.
__________________
Eric - *'92 White YJ, 4.5" custom Deaver springs, 35" MTRs, Tera-Low 4:1, CAI, Rear 8.8, Chromo D30, 4.88s, locked front/rear, full cage and front/rear tube fenders.
*'08 Silver Rubicon JKU 2.5" lift, 5.13's and 35's
matrix311 is offline   Reply With Quote Quick reply to this message
Unread 02-17-2014, 02:50 PM   #4
shu2kill
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2009
Location: chihuahua
Posts: 267
if i remember correctly it was a fuse of the fusebox under the steering wheel...
shu2kill is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.