damn lights not working again - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > damn lights not working again

Component speaker deal for your dash - NalinMFGIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSteering and more from Ruffstuff!

Reply
Unread 08-17-2011, 02:12 AM   #1
tankinyj
Registered User
2012 JK Wrangler 
 
Join Date: Jul 2011
Location: huntington, NY
Posts: 527
damn lights not working again

i understand this is a reocurring problem with YJ's. however i thought i just fixed this last week. my front headlights and yellows work fine. however my drivers/passengers side flashers arent working and my rear brake lights arent working AGAIN. we just got alot of rain here too. my passengers side rear light is on when i turn the lights on, drivers side i get nothing, however when i hit the brake the light goes out. when i hit the brakes i get no red but only white as if reverse is on (i actually thought the comp knew to throw the reverse lights on when im backing up without it in reverse such as a hill)

hints? tips? i cant figure this one out

tankinyj is offline   Reply With Quote
Unread 08-17-2011, 03:40 AM   #2
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,270
its a ground problem. Clean all the mounting surfaces where the rear lights mount. Consider running a ground wire from one of the mounting studs on the light to the frame (nicely cleaned to bare metal)
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote
Unread 08-17-2011, 05:29 AM   #3
Louie4
Powah Injanir
 
Louie4's Avatar
1993 YJ Wrangler 
 
Join Date: Aug 2008
Location: Raleigh, NC
Posts: 9,753
I agree with above to check first. The last time I had this happen the long plug on the steering column under the dash wasn't pushed in good enough. It caused my left turn signal not to work and even the brake lights though I had running lights and headlights. I was install my A/C unit back in and I think I snagged the wires and partially pulled out the plug.

One thing to try is to just reach your hand under the dash and grab and move around wires to see if the turn signals come back on. That's how I figured out my problem.


Just a thought.
__________________
Lou

I have a jeep...and it is modified...I win.

YJOTM July 2012
YJOTM February 2014

Louie4's YJ Build
Poison Spyder Fender Install
Warn M8000 Rebuild Adventure
University of Georgia
Louie4 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.