Clutch Problems after swap - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 07-08-2013, 07:13 PM Thread Starter
90JeepToy
Registered User
 
Join Date: Jul 2013
Location: Troy
Posts: 3
Clutch Problems after swap

I have a 1990 YJ Jeep Wrangler with a 4.2L AX15 with the small input shaft. I put in a Chrysler 318 LA small block. With a bellhousing, throw out bearing and flywheel from a 92' dodge dakota 3.9L. I used the original clutch and pressure plate from the 90' 4.2L. Everything is hooked up and running but when I use the slave cylinder from the dakota the clutch doesn't work at all. I tried a bleedable slave cylinder for a 94' Jeep Wrangler 4.0 The clutch pedal feels full but it release 1" off the floor. Tried different lengths of rods in the slave cylinder to bring the clutch up off the floor more but nothing has worked. Any ideas of what I can do?

90JeepToy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-08-2013, 07:34 PM
greyarea
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2009
Location: gwinett
Posts: 290
I just got my wwap done today thith the same setup only it was a magnum 318. today must be a bad day for clutches, my new slave is leaking. mine just is starting to bite 1'' off the floor and is fully engaged with another 3-4'' of travel with 1'' of free at the top. I am using a 11'' late model 318 clutch and flywheel. What are you using for a pilot bearing?

90 YJ Magnum 5.2 v8 , 1'' BL, 1'' booms, 4" Procomp, 35/12.50-15 MTR/kevlar Ford 8.8 4.10 lsd Aussie and TJ shafts up front.
KI4UTU
greyarea is offline  
post #3 of 5 Old 07-08-2013, 08:34 PM Thread Starter
90JeepToy
Registered User
 
Join Date: Jul 2013
Location: Troy
Posts: 3
I bought a pilot bushing through Novak Conversions. You might not have enough reach using the 318 flywheel and pressure plate because the hat in the pressure plate is too shallow. I ruined 2 slave cylinders before figuring this out... lol
90JeepToy is offline  
post #4 of 5 Old 07-09-2013, 11:29 PM
greyarea
Registered User
1990 YJ Wrangler 
 
Join Date: Aug 2009
Location: gwinett
Posts: 290
What master are you using? I am using a 95 yj master with the operating rod cut off my original and welded on to the 95. The oal is about 3/8'' longer than the 95 was to start. I will check the throw of the slave but I think I just got a bad slave as the boot was wet when installed.

90 YJ Magnum 5.2 v8 , 1'' BL, 1'' booms, 4" Procomp, 35/12.50-15 MTR/kevlar Ford 8.8 4.10 lsd Aussie and TJ shafts up front.
KI4UTU
greyarea is offline  
post #5 of 5 Old 07-10-2013, 06:43 PM Thread Starter
90JeepToy
Registered User
 
Join Date: Jul 2013
Location: Troy
Posts: 3
I'm using the original master. I got the clutch to work a little better by putting a 3/4" longer rod in the 94' slave driver. Seems to work it releases half way up now but it chatters a little bit when you down shift and let it out.
90JeepToy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome