CEL question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > CEL question

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits Rough Country Jeep Suspension Deals at Rockridge 4WD!

Reply
Unread 04-13-2010, 04:20 PM   #1
msprooch
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2009
Location: Kokomo, IN
Posts: 356
CEL question

When you turn on the jeep shouldn't the Cel light come on? Mine doesn't but my jeep still runs, not to well but it runs.

I know that the bulb can be bad but I wonder if my computer is dead or a bad fuse.

If this helps my seat belt light works and so does my shift light. I don't know if the ecu controls these or if something else does.

Thanks for the help.

msprooch is offline   Reply With Quote
Unread 04-13-2010, 04:24 PM   #2
idaholtby
Web Wheeler
 
idaholtby's Avatar
1991 YJ Wrangler 
 
Join Date: Apr 2008
Location: Meridian, Idaho
Posts: 2,554
Quote:
Originally Posted by msprooch View Post
When you turn on the jeep shouldn't the Cel light come on? Mine doesn't but my jeep still runs, not to well but it runs.

I know that the bulb can be bad but I wonder if my computer is dead or a bad fuse.

If this helps my seat belt light works and so does my shift light. I don't know if the ecu controls these or if something else does.

Thanks for the help.
Yes, The CEL lamp should come on when the ignition is first turned on before going to start. Because your rig still starts, I would guess that a previous owner removed or disabled the lamp to help with it's sale.
idaholtby is offline   Reply With Quote
Unread 04-13-2010, 04:28 PM   #3
msprooch
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2009
Location: Kokomo, IN
Posts: 356
Quote:
Originally Posted by idaholtby View Post
Yes, The CEL lamp should come on when the ignition is first turned on before going to start. Because your rig still starts, I would guess that a previous owner removed or disabled the lamp to help with it's sale.
Im the only owner so I didn't do that I will check the light. Thanks for the info.
msprooch is offline   Reply With Quote
Unread 04-13-2010, 04:54 PM   #4
idaholtby
Web Wheeler
 
idaholtby's Avatar
1991 YJ Wrangler 
 
Join Date: Apr 2008
Location: Meridian, Idaho
Posts: 2,554
Quote:
Originally Posted by msprooch View Post
I'm the only owner so I didn't do that I will check the light. Thanks for the info.
Pin 32 on the ecm supplies the ground for this lamp. If the bulb or it's contacts are not bad, then chase this signal back to the ecm connector. Frequently when the CEL does not illuminate when the ignition is first turned on, then it is an indication that the ecm is not powering up and the rig will then not start. This scenario is due to bad capacitors in the ecm which is easily fixed, but your rig starts. Does your lamp ever come on, even if you wait a spell before starting?
idaholtby is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.