battery draining - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > battery draining

JEEP Gear Change Packages From ROCKRIDGE 4WD. We Are DIFFSavvy Billet LED Tail LightsNEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WD

Reply
Unread 02-06-2002, 04:38 PM   #1
bigins
Registered User
 
Join Date: Feb 2002
Location: breckenridge
Posts: 4
battery draining

I HOPE SOMEONE CAN HELP. i have a 92'renegade and a battery problem. I thought it was the alternator that went out so i replaced it. got a new battery.and i am not getting a chage from the alternator or some thing is draining the battery what are some things i can check to see what is draining the battery. THANKS

bigins is offline   Reply With Quote Quick reply to this message
Unread 02-06-2002, 10:23 PM   #2
Mudpig
Registered User
 
Join Date: Feb 2002
Location: north of you
Posts: 25
gotta 12 volt test light? Disconnect your pos. battery cable. Hook up test light between the wire terminal and the battery terminal. If the test light lights up you have a parasitic draw on your battery. Pull fuses one after another till light goes out. This fuse will be your problem circuit.
__________________
It's a jeep thing, I do understand!! 89 YJ Laredo,4.2L carburated. Chrome bumpers and grill. 31 AT's on 9x15 chrome modulars. Mustang GT buckets. 3" body lift and 1 1/2" shackle lift. Completely emission & computer free. Runs great!! Took the shackle lift out, they suck!!
Soon to be SOA with 35's
Mudpig is offline   Reply With Quote Quick reply to this message
Unread 02-07-2002, 07:54 AM   #3
cobra54
Registered User
 
Join Date: Sep 2001
Location: Huntsville, AL
Posts: 52
I once had a new Olds Cutlass that the battery kept goin dead on. Turned out to be a short in the starter.
__________________
-------------
93 Red YJ 2.5L
94 Red F-150 X Cab 5.0L
01 Black Cobra 4.6L DOHC
02 ZX3 Focus 2.0L DOHC
cobra54 is offline   Reply With Quote Quick reply to this message
Unread 02-07-2002, 11:10 AM   #4
JACKED
Registered User
 
Join Date: Nov 2001
Location: NH
Posts: 90
I have a 93 YJ with hard top and defroster and found out that the defroster was stock on but no light to indicate it was on. everytime I defrosted my windows then shut off the jeep bout 8 hours later DEAD. hope that helps, probally won't but good luck.
__________________
93 YJ 4.0L 5 speed. 3" body and 4" suspension lift. 35x12.5 MT tires.
JACKED is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.