Bad miss around 2k rpm's.. HELP!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Bad miss around 2k rpm's.. HELP!!

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 07-20-2013, 04:03 PM   #1
95YJMountie
Member
 
95YJMountie's Avatar
1995 YJ Wrangler 
 
Join Date: Jun 2013
Location: Morgantown, WV
Posts: 465
Bad miss around 2k rpm's.. HELP!!

95 yj 4.0 . Misses really bad around 2k rpm's. idle is fine and so is everything else. Just around 2k rpms. So i thought id give it a tune up. Replaced plugs, wires, distributor cap, rotor button, coil, and fuel filter. Still did it. I noticed my o2 sensor was cracked so i switched it also, and its still doing it. Any ideas??

95YJMountie is offline   Reply With Quote
Unread 07-21-2013, 02:04 AM   #2
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,140
bet your fuel pump going out. Get a pressure gauge and check it
Jeepsr4me is offline   Reply With Quote
Unread 07-21-2013, 08:46 AM   #3
95YJMountie
Member
 
95YJMountie's Avatar
1995 YJ Wrangler 
 
Join Date: Jun 2013
Location: Morgantown, WV
Posts: 465
Quote:
Originally Posted by Jeepsr4me View Post
bet your fuel pump going out. Get a pressure gauge and check it
I already did, but another thing is that it only does it sometimes. It'll do it for a few days, then stop for a week. And it also kicks my check engine light on.
95YJMountie is offline   Reply With Quote
Unread 07-21-2013, 01:05 PM   #4
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,140
Well get the code and tell us what it is. Also what was the pressure readings?
Jeepsr4me is offline   Reply With Quote
Unread 07-21-2013, 07:48 PM   #5
95YJMountie
Member
 
95YJMountie's Avatar
1995 YJ Wrangler 
 
Join Date: Jun 2013
Location: Morgantown, WV
Posts: 465
Quote:
Originally Posted by Jeepsr4me View Post
Well get the code and tell us what it is. Also what was the pressure readings?
I cant get the code. Since its a 95 its still obd1 and nobody aroud here has an old obd1 scanner. And im not sure. Im gonna do another pressure test tomorrow and ill let you know. I think it might be my distributor.
95YJMountie is offline   Reply With Quote
Unread 07-24-2013, 08:51 PM   #6
95YJMountie
Member
 
95YJMountie's Avatar
1995 YJ Wrangler 
 
Join Date: Jun 2013
Location: Morgantown, WV
Posts: 465
So today i replaced my distributor... Didnt fix it. Was told that i should check my map sensor, replaced it, still didnt fix it. Then i replaced my throtle position sensor, and luckily it fixed it. So after countless hours and a wad of cash, its running great lol.
95YJMountie is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.