95 YJ 2.5 Auto Shifting issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 95 YJ 2.5 Auto Shifting issues

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 12-24-2013, 10:56 AM   #1
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
95 YJ 2.5 Auto Shifting issues

When the trans shifts from 1st to 2nd it revs up to 3500 to 4000 rpm then shifts it will drive around 30 to 35mph and scream at 3000rpm for a short time before shifting. I changed the trans fluid and filter about 700 miles ago with valvoline ATF4 full synthetic and this issue just started. I checked fluid levels and all are good. I adjusted the Tv linkage to the tranny tight then loose then right in the middle no luck. Help this is annoying the crap outta me!!

Akiepper is offline   Reply With Quote
Unread 12-24-2013, 11:28 AM   #2
Mobile_Homie
Desert Rat
 
Mobile_Homie's Avatar
1994 YJ Wrangler 
 
Join Date: Jun 2008
Location: Winnemucca, NV
Posts: 1,239
Sounds like a vacuum line came off.
__________________
Mark



Smoke em if you got em!

Click here
Mobile_Homie is offline   Reply With Quote
Unread 12-24-2013, 12:21 PM   #3
jokerchief462
Wild Wheeler
 
jokerchief462's Avatar
1989 YJ Wrangler 
 
Join Date: Nov 2010
Location: Sin City, Nevada
Posts: 2,839
Find the modulator valve. Vacuum line or bad valve.

Sent from underneath my Jeep
__________________
89YJ 2.5L TBI, AX-5, NP231 SYE, Ford 8.8, Yukon Grizzly, Tom Woods Shaft, 33" BFG T/As, 4" lift, Warn VR10000s.

AF Jeep Club Tail #184
jokerchief462 is offline   Reply With Quote
Unread 12-24-2013, 12:52 PM   #4
rshbutch
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2009
Location: fresno, ca.
Posts: 95
There is no modulator valve on a torque flight transmission. Adjust bands or rebuild it
rshbutch is offline   Reply With Quote
Unread 12-24-2013, 12:53 PM   #5
rshbutch
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2009
Location: fresno, ca.
Posts: 95
And torque flights like ORMOND fluids
rshbutch is offline   Reply With Quote
Unread 12-24-2013, 12:54 PM   #6
rshbutch
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2009
Location: fresno, ca.
Posts: 95
Oem
rshbutch is offline   Reply With Quote
Unread 12-24-2013, 01:01 PM   #7
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
What do you mean oem? Where do you get ormond fluids and which one do you recomend? I might try to adjust the bands and swap fluid soon. There was a small vac line off that goes from fuel rail down to another part. I'll take some pics. Anyway I slid the line back in the boot is that ok or do they need to be sealed?
Akiepper is offline   Reply With Quote
Unread 12-24-2013, 01:06 PM   #8
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
Another question should I disconnet the bat to reset the computer or that won't change a thing?
Akiepper is offline   Reply With Quote
Unread 12-24-2013, 03:32 PM   #9
rshbutch
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2009
Location: fresno, ca.
Posts: 95
ORMOND is a miss type....lol. o.e.m is original equipment manufacturer
rshbutch is offline   Reply With Quote
Unread 12-26-2013, 06:58 PM   #10
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
Well adjusted the bands both front and rear and there is no change what so ever. Still revs up from second to third.
Akiepper is offline   Reply With Quote
Unread 12-26-2013, 07:13 PM   #11
rshbutch
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2009
Location: fresno, ca.
Posts: 95
What does fluid look like and does it smell burnt?
rshbutch is offline   Reply With Quote
Unread 12-27-2013, 07:05 AM   #12
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
Fluid was brand new no burnt smell. I'm taking it to the trans shop Monday to see what they say.
Akiepper is offline   Reply With Quote
Unread 12-27-2013, 07:18 AM   #13
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
It revs up trying to coming out of second not 1st to 2nd as I wrote before.
Akiepper is offline   Reply With Quote
Unread 12-27-2013, 09:03 AM   #14
rshbutch
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2009
Location: fresno, ca.
Posts: 95
I don't believe synthetic transmission fluid is compatible with the older torque flights
rshbutch is offline   Reply With Quote
Unread 12-27-2013, 09:18 AM   #15
Akiepper
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2013
Location: Southington, Oh
Posts: 18
I thought about doing something different (fluid) but I didn't. I wish I would have now.
Akiepper is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.