95 bogs down while driving, please help!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 95 bogs down while driving, please help!!

Bead Lock Wheels! Raceline, Trail Ready, & Trail-Gear2007-2014 Jeep Wrangler Black (Paint to Match) Grille2007-2014 Jeep Wrangler Black Sun Shade (Rugged Ridge)

Reply
Unread 04-27-2010, 07:59 AM   #1
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
95 bogs down while driving, please help!!

I have the 2.5 in my 95 Wrangler, I just replaced the Alternator, water pump. and power steering pump, and belt, all was well, driving into work this morning, it was like I let off the gas, it bogged right down, so I stepped on the gas and off it went, it did this about 5 times in 20 miles, I have a 40 mile ride home, not looking forward to it, any ideas out there? This is the first time it has done this.

tom49329 is offline   Reply With Quote
Unread 04-27-2010, 08:08 AM   #2
Djsthe1
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2009
Location: Waldorf Maryland, Maryland
Posts: 912
Did you notice anything odd with your gauges while this was happening?
Djsthe1 is offline   Reply With Quote
Unread 04-27-2010, 08:09 AM   #3
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,954
Do a battery reset. With all the things replaced you might have stored a bad cal in the engine controller. Do a quick fault check. The method is in the FAQ. Where are you at in Michigan?
Que89YJ is offline   Reply With Quote
Unread 04-27-2010, 08:12 AM   #4
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
Gages were all good, no drops at all
tom49329 is offline   Reply With Quote
Unread 04-27-2010, 08:14 AM   #5
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
Thanks, I will try this for sure, Howard City
tom49329 is offline   Reply With Quote
Unread 04-27-2010, 08:27 AM   #6
Djsthe1
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2009
Location: Waldorf Maryland, Maryland
Posts: 912
Yea, defiantly do a reset and check for codes. Your probably not gonna get a code for anything unless your light came on.
Djsthe1 is offline   Reply With Quote
Unread 04-27-2010, 12:29 PM   #7
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
I did the battery reset, two codes came up, one for the Oxygen Sensor, the other for Air Conditioning, lol, dont have air.
tom49329 is offline   Reply With Quote
Unread 04-27-2010, 01:27 PM   #8
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,954
O2 will bog it down. You can disconnect and it will run rich but it shouldnt bog it down as much until you get the O2 replaced.
Howard City, you are in the Manistee Forest then. Great Jeeping area all around you.
Que89YJ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.