95 bogs down while driving, please help!! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 04-27-2010, 07:59 AM Thread Starter
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
95 bogs down while driving, please help!!

I have the 2.5 in my 95 Wrangler, I just replaced the Alternator, water pump. and power steering pump, and belt, all was well, driving into work this morning, it was like I let off the gas, it bogged right down, so I stepped on the gas and off it went, it did this about 5 times in 20 miles, I have a 40 mile ride home, not looking forward to it, any ideas out there? This is the first time it has done this.

tom49329 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-27-2010, 08:08 AM
Djsthe1
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2009
Location: Waldorf Maryland
Posts: 912
Did you notice anything odd with your gauges while this was happening?
Djsthe1 is offline  
post #3 of 8 Old 04-27-2010, 08:09 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,073
Do a battery reset. With all the things replaced you might have stored a bad cal in the engine controller. Do a quick fault check. The method is in the FAQ. Where are you at in Michigan?
Que89YJ is offline  
post #4 of 8 Old 04-27-2010, 08:12 AM Thread Starter
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
Gages were all good, no drops at all
tom49329 is offline  
post #5 of 8 Old 04-27-2010, 08:14 AM Thread Starter
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
Thanks, I will try this for sure, Howard City
tom49329 is offline  
post #6 of 8 Old 04-27-2010, 08:27 AM
Djsthe1
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2009
Location: Waldorf Maryland
Posts: 912
Yea, defiantly do a reset and check for codes. Your probably not gonna get a code for anything unless your light came on.
Djsthe1 is offline  
post #7 of 8 Old 04-27-2010, 12:29 PM Thread Starter
tom49329
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2010
Location: Michigan
Posts: 4
I did the battery reset, two codes came up, one for the Oxygen Sensor, the other for Air Conditioning, lol, dont have air.
tom49329 is offline  
post #8 of 8 Old 04-27-2010, 01:27 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,073
O2 will bog it down. You can disconnect and it will run rich but it shouldnt bog it down as much until you get the O2 replaced.
Howard City, you are in the Manistee Forest then. Great Jeeping area all around you.
Que89YJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Went though the Mud Bogs lilred4x4 JK Wrangler Technical Forum 4 08-04-2008 03:15 PM
bogs out when taking off? 1stJeepyj YJ Wrangler Technical Forum 6 04-06-2008 08:07 PM
YJ bogs after 1min of driving. Tazjig YJ Wrangler Technical Forum 29 02-22-2007 08:40 AM
bogs down myheapofjeep YJ Wrangler Technical Forum 3 06-04-2003 10:47 PM
Engine Bogs Down. Need Help! Fatboy YJ Wrangler Technical Forum 1 09-09-2001 05:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome