93 YJ wire harness and ECM - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 93 YJ wire harness and ECM

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 08-02-2014, 01:10 PM   #1
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
93 YJ wire harness and ECM

I recently had a underhood fusebox fire/meltdown destroyed all the wires at the fusebox ,I have a 93 YJ with an auto trans and ABS, (pretty sure the damn ABS caused the fire).I bought a 93 YJ engine harness for a manual trans everything except the ABS looks to have plugged in ,no hanging wires or left over plugs. I now have no dash light no starter no engine codes nada. Chassis electrical works fine lights blinkers ect. Even my auto hooked right up into what should be the neutral clutch switch. Does anyone know if I am just barking up the wrong tree with this harness. I am also wondering if my ECM is dead and if so how can I tell. I really think even if the harness was wrong I should then get error codes from the ECM .

any help would be fantastic

__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-02-2014, 01:41 PM   #2
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 13,945
Every time I have helped fix a fuse box melt down or engine harness melt down and fire, there were melted together shorting wires under the dash from the original short that started things off. I would be looking at the dash harness for signs of heat/melt damage.
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline   Reply With Quote Quick reply to this message
Unread 08-05-2014, 07:05 AM   #3
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,671
You have an issue with the switched ignition feed. First thing to check is with the key on check power on pins 3 and 9 of the ecu. The dome fuse in the fuse box at the drivers feet is a common issue. Post what you find on pins 3 and 9.
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 08-06-2014, 09:03 AM   #4
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
Thank you Que I am going to check that tonight ,now stupid question can I unhook the ECU connector and check there or do I have to poke through the insulation with it hooked to the ECU.
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-06-2014, 09:56 AM   #5
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,671
No, just pin the connector side with the metet lead from pin 11 ground to each of the 2 pins.
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 08-08-2014, 10:05 PM   #6
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
ok dome was blown replaced it and now fuel pump works, I have 12 volts at pins 3 and 9 but no CEL ,no gauges and no crank.
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-09-2014, 12:40 AM   #7
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,671
Bad ecu
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 08-09-2014, 03:44 AM   #8
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
looks like I may be buying some capacitors then
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-09-2014, 05:31 AM   #9
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,671
Wait. No gauges and no crank. So it doesn't even turn over?
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 08-10-2014, 08:55 AM   #10
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
Yes no starter at all
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-10-2014, 02:26 PM   #11
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
ok found another bad fuse (DOH) I now have CEL buzzers and gauges I got codes 30,55 tried grounding pin 30 still no starter
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-10-2014, 05:51 PM   #12
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,671
You have another blown fuse. Check the fuses in the pdc and the fuse box at the drivers feet.
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 08-10-2014, 07:55 PM   #13
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
Quote:
Originally Posted by Que89YJ
You have another blown fuse. Check the fuses in the pdc and the fuse box at the drivers feet.
. I am checking every damn fuse thanks Que89yj
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-18-2014, 12:27 PM   #14
orngechevy
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2008
Location: san diego
Posts: 55
I have checked all the fuses and relays all good still the starter is not getting power, still get the NSS code
__________________
Never get out of the boat
orngechevy is offline   Reply With Quote Quick reply to this message
Unread 08-18-2014, 12:53 PM   #15
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,671
Nss code? There isn't one. not fit obd1. 12 33 & 55 are normal. Take a short wire and remove the starter relay in the pdc. Briefly jumper pin 30/87 in the relay socket. It should turn the starter over just like turning the key.Post back if it turns over.
Que89YJ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.