91 won't start in cold weather? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 01-06-2008, 11:34 AM Thread Starter
medtech
Registered User
2005 LJ Wrangler 
 
Join Date: Jul 2006
Location: Mass
Posts: 57
91 won't start in cold weather?

I have a 91 yj. 4.0L. Engine is basically stock. When it's warm out, say above 50, the jeep starts fine. When it's cold it won't start. The engine will crank but there is no spark and no fuel.

Could it be the ecu? I would try a new one but they're rather expensive and I still don't know if this would fix the problem.

Sometimes when it's around 50 the check engine light will flicker very rapidly and I can hear a relay clicking. After a minute the light will come on solid and then the jeep will fire right up. Is there some other sensor that might be temperature sensitive that would cause the ecu to shut down the engine and not allow it to start?

Thanks for any help!

medtech is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-06-2008, 12:03 PM
Jeeples
Moderator
 
Jeeples's Avatar
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/
Posts: 6,565
It's possible that it may be the ECU, however a less expensive part to replace would be your Crankshaft Position Sensor. I would suspect this is to be problem since you are not getting any spark or fuel.

His: '00 WJ 4.7 Limited- Some stuff

Hers: '03 WJ 4.7 Laredo- Some more stuff


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
Originally Posted by wjjeep19 View Post
It is what Jeeples has *PARTIALLY* stated.
Jeeples is offline  
post #3 of 8 Old 01-06-2008, 04:30 PM Thread Starter
medtech
Registered User
2005 LJ Wrangler 
 
Join Date: Jul 2006
Location: Mass
Posts: 57
I've tried a new crank sensor and made sure all relays work correctly. I'll have to try a new ecu. It looks like a pain in the butt to get out, I'll have to remove the washer fluid botle too!
medtech is offline  
post #4 of 8 Old 01-06-2008, 05:24 PM
sentinal02
H2 Recovery Team Member
 
sentinal02's Avatar
1992 YJ Wrangler 
 
Join Date: Feb 2003
Location: New York
Posts: 6,681
Quote:
Originally Posted by medtech
I've tried a new crank sensor and made sure all relays work correctly. I'll have to try a new ecu. It looks like a pain in the butt to get out, I'll have to remove the washer fluid botle too!
next time try a search and read the FAQ first. I know it's long but it's got what you need in this case:

http://www.jeepforum.com/forum/f12/91-hard-no-start-long-cranks-cold-explained-490788/

RIP: '88 YJ 2.5L Ax-5 NP231
Posi-Loked. Herculined. Optima yellow top. 1" Shackle, 2" BDS. Cragar 397's Aussie front.

92 YJ 4.0L Ax-15 231
5" springs, 1" shackle 31's or 35's depending on my mood
sentinal02 is offline  
post #5 of 8 Old 01-06-2008, 08:28 PM Thread Starter
medtech
Registered User
2005 LJ Wrangler 
 
Join Date: Jul 2006
Location: Mass
Posts: 57
Excellent. Sorry for wasting your energy making you type the link!
medtech is offline  
post #6 of 8 Old 11-16-2016, 09:51 AM
tonyac17
Registered User
 
Join Date: Nov 2016
Posts: 6
I have read the post that you posted about jeeps not starting in cold weather. My issue is just a little different than the one you posted. Mine is a 2006 Jeep wrangler RHD. In the summer it will start fine. No problems. When is gets under 45 degrees it wont start. When I say wont start it will turn over once and and then you have to turn the key to the off position and then back on again. If you do this about 25-50 times it will start or when the temperature outside raises a little it will start on about the 5th try. We took it to the jeep dealership last week thinking they would be able to fix the problem. $300 and a new crankshaft sensor later still will not start. If we park it in the garage and run a heater it will start. I deliver mail so I never know when I can get called in so not able to keep it in the garage with a heater every night. Just hoping you can help me with my problem.
Thanks
Tonya

Last edited by tonyac17; 11-16-2016 at 05:14 PM.
tonyac17 is offline  
post #7 of 8 Old 11-16-2016, 11:54 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,837
Tony you need to post to this forum:
http://www.jeepforum.com/forum/f96/

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #8 of 8 Old 11-16-2016, 05:18 PM
tonyac17
Registered User
 
Join Date: Nov 2016
Posts: 6
Ok..thanks
tonyac17 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Cold Weather Start - Grinding ten27oh4 JK Wrangler Technical Forum 19 01-04-2011 03:52 PM
Cold Start New to Cold Weather Thexonexkid TJ Wrangler Technical Forum 18 12-02-2009 01:39 PM
Hard to start in Cold Weather Kiwi_TJ TJ Wrangler Technical Forum 4 06-05-2009 07:31 AM
low screeching noise on start up in cold weather jeep n00b YJ Wrangler Technical Forum 8 12-05-2008 02:28 PM
start up problems during cold weather 88JeepYJ YJ Wrangler Technical Forum 2 01-06-2004 03:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome