90YJ Dead in the water - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 90YJ Dead in the water

ECGS Black Friday Sale!!6th Annual, Beat Your Wife to the Credit Card Sale!50 in light bar /A pillar mount less than 500 at JeepHut.c

Reply
Unread 09-26-2013, 06:08 PM   #1
boatsandhose
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: North Logan, UT
Posts: 134
90YJ Dead in the water

So I have a 90 YJ 2.5l. It's had it's fair share of problems that I think mostly result from the shoddily done engine rebuild by the PO. Anyways went to work the other day, jeep ran really good. Got off of work, went to turn it on and I didn't hear the fuel pump buzz like usual. Cranked it anyways for some reason and it just cranked and cranked like it had no fuel. Light smoke started coming out from the battery tray/ ignition coil at this point. Stopped and turned it off and on to try again and no cranking this time. No power to anything except stuff not requiring the jeep to be on (headlights, winch, hazards). I can't even turn my wipers on when I go to the on position in the ignition. So I checked my fuses and turns out I blew #2. It is a 20 amp fuse labeled "DOME". I have had issues with this one in the past when I replaced the fuel pump and that was the one that had blown. Once I replaced that fuse still nothing. I am stumped. Sorry for the wall of text, anyone have any ideas? For preface the distributor, cap, rotor, starter, plugs, and fuel pump were replaced this last spring/ early summer.

__________________
90 YJ 2.5L Posilock, metalcloak front bumper, superwinch lp8500, teraflex hand throttle, genright rocker gaurds, 33x12.5x15 BFG KM2s. Swaybar and Trackbar MIA.
boatsandhose is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 06:50 PM   #2
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 5,135
sounds like corrosion on the terminals AND maybe a bad fuel pump./ Cause you should hear it come on.
Jeepsr4me is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 08:03 PM   #3
boatsandhose
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: North Logan, UT
Posts: 134
The terminals are clean, I was thinking a bad ground by the fuel pump, but that wouldn't explain the no power deal.

Sent from my Galaxy Nexus
__________________
90 YJ 2.5L Posilock, metalcloak front bumper, superwinch lp8500, teraflex hand throttle, genright rocker gaurds, 33x12.5x15 BFG KM2s. Swaybar and Trackbar MIA.
boatsandhose is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 08:43 PM   #4
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 5,135
How are you sure they clean? I have seen ones that look perfect on outside, but be solid crudded up when you look on the inside of the terminal. Should be shiny..
Jeepsr4me is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 09:14 PM   #5
boatsandhose
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: North Logan, UT
Posts: 134
Well if they are corroded then why do my headlights and such work? The battery is pretty old (probably 5 years or so).

Sent from my Galaxy Nexus
__________________
90 YJ 2.5L Posilock, metalcloak front bumper, superwinch lp8500, teraflex hand throttle, genright rocker gaurds, 33x12.5x15 BFG KM2s. Swaybar and Trackbar MIA.
boatsandhose is offline   Reply With Quote Quick reply to this message
Unread 09-27-2013, 02:29 AM   #6
Michaelgoesrawr
Web Wheeler
 
Michaelgoesrawr's Avatar
1988 YJ Wrangler 
 
Join Date: Nov 2009
Location: Waco, TX
Posts: 7,066
Quote:
Originally Posted by Jeepsr4me
How are you sure they clean? I have seen ones that look perfect on outside, but be solid crudded up when you look on the inside of the terminal. Should be shiny..
I've had ones look good inside and out and snap in half because they were corroded inside.
__________________
Adopt your pets. Don't shop for them.
Michaelgoesrawr is online now   Reply With Quote Quick reply to this message
Unread 09-27-2013, 05:26 PM   #7
boatsandhose
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: North Logan, UT
Posts: 134
Got it running, for anyone wondering, I had a burnt up wire down there.
__________________
90 YJ 2.5L Posilock, metalcloak front bumper, superwinch lp8500, teraflex hand throttle, genright rocker gaurds, 33x12.5x15 BFG KM2s. Swaybar and Trackbar MIA.
boatsandhose is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.