87 YJ making a clicking noise when stopping - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 87 YJ making a clicking noise when stopping

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 05-21-2009, 05:21 AM   #1
SSDDYJ
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2008
Location: Concord N.C.
Posts: 2
87 YJ making a clicking noise when stopping

87 YJ I-6 TF999 and NP-207 making clicking noise from either transfer case or transmission, replaced all brakes and disconnected front driveshaft and nothing helps. Does not make noise any other time only when on the brakes fairly hard. Any suggestions would help

Thanks

SSDDYJ is offline   Reply With Quote Quick reply to this message
Unread 05-21-2009, 05:28 AM   #2
agentr855
Registered User
1995 YJ Wrangler 
 
Join Date: Jun 2008
Location: maine
Posts: 114
could be some really bad end play in your transfer or transmission shafts... does any gear grind when shifting? i had this same problem when 3rd went.
__________________
_______ Only in a YJ
/l ,[_____],
l---L -[]lllllll[]-
()_)-()_)--o-)_)
agentr855 is offline   Reply With Quote Quick reply to this message
Unread 05-21-2009, 06:58 AM   #3
championdada
Registered User
1992 YJ Wrangler 
 
Join Date: Apr 2009
Location: Dubai
Posts: 2
hey SSDDYJ ... what next, did you manage to solve this problem
championdada is offline   Reply With Quote Quick reply to this message
Unread 05-21-2009, 07:13 AM   #4
SSDDYJ
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2008
Location: Concord N.C.
Posts: 2
transfer case works fine in 4 high,4 low and 2 high and transmission shifts great, I'm stumped
SSDDYJ is offline   Reply With Quote Quick reply to this message
Unread 05-21-2009, 07:15 AM   #5
unideluxe
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2008
Location: Rehoboth, MA
Posts: 203
How is your transmission mount? Mine was a little loose causing the drive shaft to rotate against the muffler shield when braking causing a 'clicking' noise.
__________________
1993 BLACK Wrangler, 1.5" shackle lift, CJ hardtop, rest is stock....dang it college.

Quote:
Originally Posted by Ribramax View Post
If you ain't bustin' it you ain't usin' it. If you ain't usin' it you don't need it.
Support Jeep Forum!! Equipment Drive
unideluxe is offline   Reply With Quote Quick reply to this message
Unread 05-21-2009, 02:55 PM   #6
JRD917
Registered User
1987 YJ Wrangler 
 
Join Date: Apr 2008
Location: El Paso , Tx
Posts: 126
i had the same thing with mine ... before i put mylift on come to find out .... after i installed my lift i got to looking it was one of two things casueing it ...i had bad shock bushings plus i had a bad transfer mount casueing it to rock and tap against the tail pipe from time to time casueing a tapping sound ???? take your pick lol
__________________
All jacked up on Mt Dew, And commin at you like a Spider Monkey !!!!
JRD917 is offline   Reply With Quote Quick reply to this message
Unread 10-26-2012, 09:40 PM   #7
lanny94
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2012
Location: poco, bc
Posts: 13
instead of makin new thread figured id bump an old one so i have a harsh clicking sound when im slowing down seems to do it only in 2 wheel since it only started doin it on the way home after wheeling. o and my pinion angle is completly buggered cause i lost my driveshaft shims those will be getting replaced asap
lanny94 is offline   Reply With Quote Quick reply to this message
Unread 10-26-2012, 10:01 PM   #8
mrmark
Registered User
1994 YJ Wrangler 
 
Join Date: Apr 2011
Location: Orange Park, FL
Posts: 1,951
Quote:
Originally Posted by lanny94 View Post
instead of makin new thread figured id bump an old one so i have a harsh clicking sound when im slowing down seems to do it only in 2 wheel since it only started doin it on the way home after wheeling. o and my pinion angle is completly buggered cause i lost my driveshaft shims those will be getting replaced asap
You have to make sure the DS is right and then retest as it could have been your problem all along.

it would be hard to tell what is wrong if everything else is not correct.
__________________
Wave as you pass me :D

The problems of owning 2 Jeeps ... I never know which one to work on or which YJ gets the next mod ...
mrmark is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.