4.2 banging sound - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 06-20-2010, 03:41 PM Thread Starter
Zutroy
Registered User
1989 YJ Wrangler 
 
Join Date: Jan 2010
Location: Providence Rhode Island
Posts: 57
4.2 banging sound

Well, I changed the motor mounts and tranny mounts last week. When I started it up it ran a little rough, stalling a bit while cold. I figured it ran a little rough before and I was just feeling it more because of the new mounts. So I noticed a bit of a rattle on the highway. After a couple days I started her up and the rattle has become a bang. It will run but just on the verge of stall. I took off the valve cover and all seems good. I dropped the pan and checked all the bearings. Also look good. Noticed the timing chain is a bit loose so I'll check that out, but I don't think that is it. Any ideas? I really don't know very much about diagnosing problems. I just take things apart a see what looks busted.

By the way, Noticed a while back that oil pressure runs around 60 until it gets warm. Then it runs around 40 when I am on the gas but about 5 at idle. ? Don't know if that means anything.

Zutroy is offline  
Reply

Tags
4.2

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Banging sound when shifting, clutch? eric411420 YJ Wrangler Technical Forum 21 12-15-2009 11:27 PM
Banging Sound at Take Off 1st Gear HanksRide YJ Wrangler Technical Forum 16 05-17-2009 08:08 PM
Knocking/Banging sound capecodtjeep TJ Wrangler Technical Forum 6 02-24-2005 09:18 PM
I found that metal banging sound, now what is it cspann TJ Wrangler Technical Forum 16 02-18-2004 06:58 PM
post trail problem-loud banging sound johnniebravo TJ Wrangler Technical Forum 14 11-13-2002 11:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome