4.2 banging sound - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 4.2 banging sound

Rough Country Lift Kits and Parts!1999-2004 Jeep Grand Cherokee Limited Headlight Pair1997 - 2001 Jeep Cherokee Header Panel

Reply
Unread 06-20-2010, 02:41 PM   #1
Zutroy
Registered User
1989 YJ Wrangler 
 
Join Date: Jan 2010
Location: Providence Rhode Island, Rhode Island
Posts: 57
4.2 banging sound

Well, I changed the motor mounts and tranny mounts last week. When I started it up it ran a little rough, stalling a bit while cold. I figured it ran a little rough before and I was just feeling it more because of the new mounts. So I noticed a bit of a rattle on the highway. After a couple days I started her up and the rattle has become a bang. It will run but just on the verge of stall. I took off the valve cover and all seems good. I dropped the pan and checked all the bearings. Also look good. Noticed the timing chain is a bit loose so I'll check that out, but I don't think that is it. Any ideas? I really don't know very much about diagnosing problems. I just take things apart a see what looks busted.

By the way, Noticed a while back that oil pressure runs around 60 until it gets warm. Then it runs around 40 when I am on the gas but about 5 at idle. ? Don't know if that means anything.

Zutroy is offline   Reply With Quote
Reply

Tags
4.2
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.