4.0l xj 97 motor into yj 87 - Page 14 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #196 of 252 Old 10-21-2013, 01:32 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
update on the codes
i have solved 2 codes p1698,p1899 this was due to a gummed up NSS switch,
just a good old klean and bobs your uncle all new.

just got to deal with these codes:



p0443 evap sensor
p0132 o2 sensor bank 1
p0700 transmmision (mil request)
p0463 fuel sender unit (high voltage)
p1492 battery temp sensor
p1685 SKIM KEY cant figure this one out



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
Sponsored Links
Advertisement
 
post #197 of 252 Old 10-21-2013, 02:25 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,863
O2 effects calibration. It's a must Fix

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #198 of 252 Old 10-21-2013, 02:54 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Yes im off to my local 4x4 get one and to clear the codes and then see what happens,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #199 of 252 Old 10-21-2013, 03:37 PM
SLO_Ken
Registered User
1986 CJ7 
 
Join Date: Nov 2009
Location: California
Posts: 1,052
P0443 (M) Evap Purge Solenoid Circuit. An open or shorted condition detected in the EVAP purge solenoid control circuit.

P0700 ETAX Controller DTC Present. This SBEC III or JTEC DTC indicates that the EATX or Aisin controller has an active fault and has illuminated the MIL via a CCD (EATX) or SCI (Aisin) message. The specific fault must be acquired from the EATX via CCD or from the Aisin via ISO-9141.

P1685 SKIM Invalid Key. The engine controler has received an invalid key from the SKIM.
For added system security, each SKIM is pro- grammed with a unique “Secret Key” code and a security code. The SKIM keeps the “Secret Key” code in memory and sends the code over the CCD data bus to the PCM, which also keeps this code in its memory.
Attached Files
File Type: pdf EXJ_8Q.PDF (56.7 KB, 19 views)
SLO_Ken is offline  
post #200 of 252 Old 10-21-2013, 04:11 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by SLO_Ken View Post
P0443 (M) Evap Purge Solenoid Circuit. An open or shorted condition detected in the EVAP purge solenoid control circuit.

P0700 ETAX Controller DTC Present. This SBEC III or JTEC DTC indicates that the EATX or Aisin controller has an active fault and has illuminated the MIL via a CCD (EATX) or SCI (Aisin) message. The specific fault must be acquired from the EATX via CCD or from the Aisin via ISO-9141.

P1685 SKIM Invalid Key. The engine controler has received an invalid key from the SKIM.
For added system security, each SKIM is pro- grammed with a unique “Secret Key” code and a security code. The SKIM keeps the “Secret Key” code in memory and sends the code over the CCD data bus to the PCM, which also keeps this code in its memory.
OK p0443 i get that iTS an open loop fuel system fail.

P0700 can you lay that in git languge

Skim key ill do the test from that PDF file.

The p0433 code it that why im getting hesitation when turnning left and right as if its not getting fuel it feeds like it wants to shut off?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #201 of 252 Old 10-21-2013, 04:18 PM
Varnish
Registered User
 
Varnish's Avatar
1998 TJ Wrangler 
 
Join Date: Feb 2005
Location: Juneau, AK
Posts: 4,385
Garage
For the p0443, on the cherokee there is a evap control solenoid on the firewall and then the charcoal canister box above the rear driveshaft, did you transfer those items over during the swap?

'98 TJ, '06 LJ, '88 YJ, '86 CJ, '99 XJ 4dr Ltd
Varnish is offline  
post #202 of 252 Old 10-21-2013, 04:24 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by Varnish View Post
For the p0443, on the cherokee there is a evap control solenoid on the firewall and then the charcoal canister box above the rear driveshaft, did you transfer those items over during the swap?
Yes i got them, the charcoal canister was not at the rear drive shaft, it was onder the hood.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #203 of 252 Old 10-21-2013, 06:57 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,863
The battery temperature and the o2 are the only 2 that effect calibration. Fix those first. Did you grab the sensor on the battery tray? O2 first

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #204 of 252 Old 10-22-2013, 09:31 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by Que89YJ View Post
The battery temperature and the o2 are the only 2 that effect calibration. Fix those first. Did you grab the sensor on the battery tray? O2 first
No i didnt get the temp sender for the battery i can still get a hold of it, i was also thinking of just getting a resistor for that then i can get the code cleared.

i checked the fuse box at PDC, fuse f27 10A was gone so replaced that and went of down to the local 4x4 garage, to clear the codes to see what happens good news the p0700 code has gone

after clearing all the code the only ones that came back were the batt temp sens and the fuel gauge high voltage.

About the fuel gauge sending meter says high voltage, like i said earlier should i connect the fuel tank sending unit meter op to the computer so that will clear that code as well.

Anyway back home i thought i would see if i still got the codes that kept coming back and yes they came back only 5 to deal with,
the garage didn't have a 02 sens nor did they have a evap sensor,
so called the cherokeeparts.nl over heir and they have what i need it is second hand and tested, they said they will exchange the parts if they are no good.
i cant afford new so hopefully i can get away with these parts till my next pay day.

heirs the codes ive got left,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #205 of 252 Old 10-22-2013, 10:13 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,863
You can hook up thefuel input but it does not effect the calibration. The temp sensor effects the output for the alternator and the cal as does the O2 sensor. You should have been able to use a generic O2 sensor for your fault. Bosch makes a universal that should be available in your area. The resistor will work for the battery temp.
Que89YJ is offline  
post #206 of 252 Old 10-22-2013, 10:18 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by Que89YJ View Post
You can hook up thefuel input but it does not effect the calibration. The temp sensor effects the output for the alternator and the cal as does the O2 sensor. You should have been able to use a generic O2 sensor for your fault. Bosch makes a universal that should be available in your area. The resistor will work for the battery temp.
ok just got word on the battery temp sensor it on its way

o2 sensor i m looking now
also to see if i can purge valve solenoid sensor.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #207 of 252 Old 10-22-2013, 01:30 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
ive bean looking into the p0443 code and that is for the Purge Control Valve Circuit

Read more at: http://www.obd-codes.com/p0443
Copyright © OBD-Codes.com

i found this and tested to the best of my ability im getting 32.4ohms on the solenoid.
when i turn the motor on the use the volt meter to check the feed wire(white) on the connector im getting about 14v.
also had taken the solenoid out of the motor bay and connected it straight up to a 12v battery i have laying around, it clicks so thats ok the only thing i dont under stand is this, where is the ECM ground?

3. To check for a problem on the control circuit (if the solenoid tests okay and you have voltage to the solenoid) plug the solenoid back in and remove the control circuit (ground) wire from the ECM connector (If you're unsure how to do this, do not attempt). With the ground wire removed from the ECM, turn the key on and then manually ground the Purge valve control wire. The solenoid should click. If it does, then you know there is no problem with the control wire to the solenoid and there is a problem with the ECM purge solenoid driver circuit in the ECM. You'll need a new ECM. However if it doesn't click, then there must be an open in the wiring between the ECM and and the solenoid. You must find it and repair it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #208 of 252 Old 10-22-2013, 01:38 PM
Varnish
Registered User
 
Varnish's Avatar
1998 TJ Wrangler 
 
Join Date: Feb 2005
Location: Juneau, AK
Posts: 4,385
Garage
Assuming it is like most things the ECM controls, the ECM grounds the solenoid, so it isn't so much an ECM ground as the ground wire for the solenoid goes through the ECM and the ECM controls whether the solenoid is grounded.

'98 TJ, '06 LJ, '88 YJ, '86 CJ, '99 XJ 4dr Ltd
Varnish is offline  
post #209 of 252 Old 10-22-2013, 01:53 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by Varnish View Post
Assuming it is like most things the ECM controls, the ECM grounds the solenoid, so it isn't so much an ECM ground as the ground wire for the solenoid goes through the ECM and the ECM controls whether the solenoid is grounded.
ok so what do you sugest to do for the test 3 in my last post


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #210 of 252 Old 10-22-2013, 01:58 PM
SLO_Ken
Registered User
1986 CJ7 
 
Join Date: Nov 2009
Location: California
Posts: 1,052
The solenoid ground/control wire is pink/black, position C20 on the Grey ECM connector.
SLO_Ken is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome