4.0l xj 97 motor into yj 87 - Page 13 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #181 of 252 Old 10-18-2013, 11:17 AM
SLO_Ken
Registered User
1986 CJ7 
 
Join Date: Nov 2009
Location: California
Posts: 1,034
This is when having a functional OBDII diagnostic port would be very helpful.

SLO_Ken is offline  
Sponsored Links
Advertisement
 
post #182 of 252 Old 10-18-2013, 11:35 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by SLO_Ken View Post
The first things that come to mind are the crank position sensor (CPS), and the immobilizer. The second part, about it dying 2-3 seconds after startup definitely sounds like the immobilizer.
if its the immobilizer then how can i go about checking that?

also like you and Que98YJ say (CPS) Do you happen to have a link on how to diagnose that.

http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #183 of 252 Old 10-18-2013, 11:42 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,167
I think you need to read the diagnostics. Did you hook up the J1962 connector to do diagnostics? It is the standard plug to read the codes.
Que89YJ is offline  
post #184 of 252 Old 10-18-2013, 11:52 AM
SLO_Ken
Registered User
1986 CJ7 
 
Join Date: Nov 2009
Location: California
Posts: 1,034
Quote:
Originally Posted by Que89YJ View Post
I think you need to read the diagnostics. Did you hook up the J1962 connector to do diagnostics? It is the standard plug to read the codes.
It looks like this...
SLO_Ken is offline  
post #185 of 252 Old 10-18-2013, 12:15 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
yes i got the date link all hooked up just no Bluetooth adapter so i can read off my phone, i suppose i will have to order one.
couldt it be that im using the spear key and all taped up in the immobilizer

I ordered a new filter but that not heir till next week so i made one out of the what i had left from the xj aif filter box,and some drain pipe for now.
i couldn't wait for the filter


http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #186 of 252 Old 10-18-2013, 12:18 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,167
No, the key doesnt matter. It starts or it doesnt with the immobilizer. You need to do the diagnostics.
Que89YJ is offline  
post #187 of 252 Old 10-18-2013, 12:22 PM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
ok ive found a few over hier local for about €15 so ill go pick that up morrow

ive also read that it could also be the fuel pump, will that also show as a fault code?

http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #188 of 252 Old 10-18-2013, 04:01 PM
Varnish
Registered User
 
Varnish's Avatar
1998 TJ Wrangler 
 
Join Date: Feb 2005
Location: Juneau, AK
Posts: 4,369
Garage
How much gas is in the tank, cutting out in corners happens when I get real low.

'98 TJ, '06 LJ, '88 YJ, '86 CJ, '99 XJ 4dr SE
Varnish is online now  
post #189 of 252 Old 10-18-2013, 07:39 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,167
It will but not directly. Post the codes.
Que89YJ is offline  
post #190 of 252 Old 10-19-2013, 03:33 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by Varnish View Post
How much gas is in the tank, cutting out in corners happens when I get real low.
more than a 1/4 full tank so its not that, but it still strange when turning corners.

http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #191 of 252 Old 10-19-2013, 03:39 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Quote:
Originally Posted by Que89YJ View Post
It will but not directly. Post the codes.
it says i have no pending fault codes.

and these are logged codes






http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #192 of 252 Old 10-19-2013, 05:02 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
i wasnt getting any where with the torque lite app so i went looking for an other app called Carista , gave me these fault codes





http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #193 of 252 Old 10-19-2013, 08:12 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,167
You need to clear the codes and drive it again. I thought it was o2
Que89YJ is offline  
post #194 of 252 Old 10-19-2013, 08:19 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Thanks,
I'll do that morrow im writing all the codes down and naming them then ill check them one bij one if they all come back after the reset.

http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
post #195 of 252 Old 10-19-2013, 11:43 AM Thread Starter
lbsickboy
Registered User
1986 YJ Wrangler 
 
Join Date: Aug 2011
Location: Den Haag
Posts: 193
Ok so codes,

P0132 EVAP sensor
P0132 o2 sensor bank 1 down pipe front exhuast ( http://www.doityourself.com/stry/how...xygen-sensor#b
P1698 Transmission speed sensor
P1899 park/neutral switch
P0700 TCM automatic transmission
P0463 Fuel sending unit volts high this is i think because i dont have it conected up to as we all know im waiting on the new gauge(would it bea good idea to connect it up when the gauge comes in?)
P1492 Evap canister purge control/valve circuit
P1685 SKIM invalid key ( i will swap out Keys)

http://www.jeepforum.com/forum/f12/4-0l-xj-97-motor-into-yj-87-a-1567705/
WANGLER 87 4.0 HO AW4
4,5 " ROUGH COUNTRY LIFT KIT, 1.5" BOOMERANG SHACKLES, 33'' BANDEN, ROUGH COUNTRY DUAL STEERING STABILIZER
lbsickboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome