2.5l to 4.0l Throttle Body swap problem! No idle and Revs goes straight to Redline! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 2.5l to 4.0l Throttle Body swap problem! No idle and Revs goes straight to Redline!

We still have some great deals going on!Year End Clearance Sale! Save 20%Santa Kolak Announces: Kolak Exhaust 20% Off Sale!

Reply
Unread 08-01-2010, 10:32 AM   #1
JTR2008
Registered User
1994 YJ Wrangler 
 
Join Date: Dec 2009
Location: Columbus, OH
Posts: 17
2.5l to 4.0l Throttle Body swap problem! No idle and Revs goes straight to Redline!

So I just swapped out my 2.5L throttle body and put in a 4.0L throttle body. everything went in smooth and everything is on tight, and I used the original sensors but when i turn the key and start the car, the revs just go straight up and doesn't stop and i shut the engine off right away. I checked the the flap and its staying shut. I'm no mechanic and i don't have a clue why it is doing this. Any help would be great.

JTR2008 is offline   Reply With Quote Quick reply to this message
Unread 08-01-2010, 10:41 PM   #2
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,707
You have a vacuum leak. Check all the vacuum lines.
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 09-08-2010, 07:41 AM   #3
YelloJeep
Registered User
1991 YJ Wrangler 
 
Join Date: Jan 2010
Location: Simpsonville, SC
Posts: 542
Quote:
Originally Posted by JTR2008 View Post
So I just swapped out my 2.5L throttle body and put in a 4.0L throttle body. everything went in smooth and everything is on tight, and I used the original sensors but when i turn the key and start the car, the revs just go straight up and doesn't stop and i shut the engine off right away. I checked the the flap and its staying shut. I'm no mechanic and i don't have a clue why it is doing this. Any help would be great.
Did you get this straightened out? I also just did this swap and when I started it I held my breath waiting for the RPM's to shoot up (I keep hearing people say that is what happens) but it started right up as if I had done nothing. I did notice that it idles around 900-1000RPMs but I can deal with that. I have noticed a pretty good difference in power (not HUGE..). I see alot more of 5th gear and I think maybe I can now turn some 33's without too much strain... Before I was thinking 33's would just be too much but now I think it can handle it.
YelloJeep is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.