2.5 yj Wont start, Searched forums like Crazy! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 2.5 yj Wont start, Searched forums like Crazy!

OPTIC ARMOR WINDOWS all sale now !!!!!!!!Alloy USA and Posi-Lok Cable Axle Disconnect Kits Dana 30 Spartan Locker Special Forum Prices Dana 30 44 60 Ford 8.8

Reply
Unread 06-04-2013, 07:31 PM   #1
spyder1
Registered User
 
Join Date: Nov 2010
Location: bpt, ct
Posts: 3
2.5 yj Wont start, Searched forums like Crazy!

Hey guys I don't post threads really because I search a lot and usually find my answers. But here's my problem, 94 2.5l will crank but won't start. I have spark, fuel, and compression ( one cylinder is 100psi the rest are 140psi) and the motor won't start. I did the ECU check, and I hear the fuel pump and CEL comes on when I turn the key. Fuses and relays all seem good. When I crank I hear a loud air puffs coming from my exhaust manifold downpipe connection that I never heard before. But otherwise then that is it possible that my ECU is still bad even though the fuel pump and CEL still works?

spyder1 is offline   Reply With Quote
Unread 06-04-2013, 07:38 PM   #2
goinggonzo92
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2013
Posts: 8
I had the same issue on my 92 jeep wrangler yj and checked a fuse in the fuse box by my battery marked (Fuel System ECU). I pulled it out and noticed it had a lot of corrosion on the fuse terminal, cleaned it up real good, plugged it back in and it started right up. Hope this little information helps as wouldnt hurt to check and it wouldnt cost you a penny unless you buy a new one. Good luck
goinggonzo92 is offline   Reply With Quote
Unread 06-04-2013, 08:05 PM   #3
idaholtby
Web Wheeler
 
idaholtby's Avatar
1991 YJ Wrangler 
 
Join Date: Apr 2008
Location: Meridian, Idaho
Posts: 2,554
Quote:
Originally Posted by spyder1 View Post
Hey guys I don't post threads really because I search a lot and usually find my answers. But here's my problem, 94 2.5l will crank but won't start. I have spark, fuel, and compression ( one cylinder is 100psi the rest are 140psi) and the motor won't start. I did the ECU check, and I hear the fuel pump and CEL comes on when I turn the key. Fuses and relays all seem good. When I crank I hear a loud air puffs coming from my exhaust manifold downpipe connection that I never heard before. But otherwise then that is it possible that my ECU is still bad even though the fuel pump and CEL still works?
My experience has always meant that an "Air Puff" is usually indicative of the timing being way off. Verify your timing. Does the rotor point to the #1 cylinder on the compression stroke at TDC? Have you done any work related to the distributer recently before this issue arose?
idaholtby is offline   Reply With Quote
Unread 06-05-2013, 06:40 AM   #4
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 13,694
The other thread you mentioned is probably dealing with a bad ecu since he doesnt have the CEL. Your problem is definitely different and I really didnt want to confuce you on the thread with some of the checks he needs to do.

You have good compression so the timing has to be on. You hear the fuel pump come on but that doesnt mean you are getting correct fuel to the rail. Always check your fault codes:
http://www.jeepforum.com/forum/f12/h...codes-1257145/

Depress the schrader on the fuel rail and see if you have fuel coming out of the rail. If you do the try a shot of starter fuid directly into the throttlebody and see if it cranks. I would also consider doing the fuel pressure test. You can borrow the pressure guage from any of the big parts stores with a fully refunable deposit. 31 psi at idle and 39 psi when it runs.

The last possibility is the spark is occuring at the wrong time or is weak. Is the spark blue color? Did you check it and make sure it is at a good repitition? There is a possibility that the pickup sensor in the distributor is bad and if that is the case you can get one and replace it or with the entire distributor. The later is the best choise IMO. It is $about $25.00 more and work every penny of it.
Que89YJ is offline   Reply With Quote
Unread 06-05-2013, 06:07 PM   #5
spyder1
Registered User
 
Join Date: Nov 2010
Location: bpt, ct
Posts: 3
Thanks guys for the help... it was my distributor timing...! Adjusted and started right up.! Thanks, you guys rock!
spyder1 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.