2.5 Injector issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 2.5 Injector issue

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 05-17-2013, 08:11 PM   #1
Noah0z
Registered User
1988 YJ Wrangler 
 
Join Date: May 2012
Location: Tuscaloosa, AL
Posts: 8
2.5 Injector issue

As of late my 88 2.5 has has a couple of sluggish moments so Ive been exploring my fuel systems issues. It was running prior to this but I'd read somewhere to remove the injector and check the screen for debris. After I checked the spring I put my injector back in but it seems to be spraying fuel out the top a bit and refuses to start. It started a few times in a row today before I ever touched the injector so in pretty sure something went wrong there.

Any ideas?

Noah0z is offline   Reply With Quote
Unread 05-20-2013, 11:27 AM   #2
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,755
It sounds like youscrewed up the injector some how. Here are links to the FSM.
http://dl.dropboxusercontent.com/u/4...e%20Manual.pdf
http://dl.dropboxusercontent.com/u/4...M%20manual.pdf

Here is a link to Shaef's tbi rebuild:
http://www.jeepforum.com/forum/f12/8...ocess-1293442/

The 87-90 TBI all have a renix controller and several adjustments. You wil need a meter to do them. Sluggish moments migh be an issue with the O2 sensor. First things first, look at the threads and try and get it going.
Que89YJ is online now   Reply With Quote
Unread 05-31-2013, 08:55 AM   #3
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,755
wrong thread! deleted
Que89YJ is online now   Reply With Quote
Unread 06-01-2013, 09:36 AM   #4
Noah0z
Registered User
1988 YJ Wrangler 
 
Join Date: May 2012
Location: Tuscaloosa, AL
Posts: 8
Thanks for the help. It ended up being the larger on-ring on the injector. I didn't know it was supposed to be there but I saw it in he FSM. Couldn't find the on I had lost so I went to the parts store and picked up a variety till I found one that worked. I then pulled the fuel pump relay and purged the gas that had flooded into the intake. Turned it over till it started and then put the relay back in. Its running again but I'm back to square one so i bought a TBI rebuild kit and a fuel filter. I'm hoping I'm narrowing down the issue.
Noah0z is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.