2.5 hard start cold, rough idle, sometimes stalls - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 12-31-2009, 04:44 PM Thread Starter
91wrangler4cyl
Registered User
1991 YJ Wrangler 
 
Join Date: Dec 2009
Location: western pa
Posts: 3
2.5 hard start cold, rough idle, sometimes stalls

A couple of months ago we picked up a 91 YJ 2.5 5 speed.
Never noticed that there were pliers on the throttle body keeping the rpms up. When they are removed the cel comes on and it idles rough and sometimes stalls at stop signs. We've done a tune up and changed the idle speed motor and still get the these codes 12,33,24,21,15.
I was going to change the o2 sensor and the tps tomorrow. Any other ideas?
Thanks.

91wrangler4cyl is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-01-2010, 09:29 AM
idaholtby
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2008
Location: Meridian
Posts: 2,565
Quote:
Originally Posted by 91wrangler4cyl View Post
A couple of months ago we picked up a 91 YJ 2.5 5 speed.
Never noticed that there were pliers on the throttle body keeping the rpms up. When they are removed the cel comes on and it idles rough and sometimes stalls at stop signs. We've done a tune up and changed the idle speed motor and still get the these codes 12,33,24,21,15.
I was going to change the o2 sensor and the tps tomorrow. Any other ideas?
Thanks.
15 is the VSS signal for the ECM. It is located on the transfer case and also has the speedometer cable attached to it being how you have a '91. I've seen the VSS senders for the '91's on e-bay recently pretty cheap for around 27 bucks, other wise auto part stores ask around $80 for them.
Here is the link to the e-bay VSS... JEEP DODGE TRANSMISSION SPEED SENSOR 56027014 SC109:eBay Motors (item 160388653461 end time Jan-18-10 16:23:40 PST)

I would also suggest to get a new throttle body gasket and remove the throttle body to give it a good cleaning while you replace the TPS. Sounds like your P.O. was more into masking problems rather than fixing them. The O2 and TPS should address codes 21 and 24. 12 and 33 are normally stored and do not trip the CEL. 12 is battery disconnect within the last 50 starts and 33 is no signal from the A/C relay which means your rig doesn't have A/C. Good luck!
idaholtby is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1997 2.5 will not start on incline and rough start/idle when cold. BuckeyeTJ TJ Wrangler Technical Forum 0 11-24-2009 10:39 AM
Key on clicking sound, rough idle on cold start, pcm resetting itself nshock TJ Wrangler Technical Forum 2 10-10-2009 06:59 PM
'90 Violent Cold Start Up, Rough Idle, No Vacuum Leaks. Delta347 YJ Wrangler Technical Forum 24 01-03-2009 11:58 PM
Rough idle and hard start '89 2.5L Matt_vs_YJ YJ Wrangler Technical Forum 19 04-18-2008 07:38 PM
Rough Idle on Cold Start rugbynut YJ Wrangler Technical Forum 15 03-13-2008 01:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome