2.5-4.0tb issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 2.5-4.0tb issue

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 01-17-2014, 09:58 PM   #1
Overhead
You built a 4cyl?
 
Overhead's Avatar
1995 YJ Wrangler 
 
Join Date: May 2011
Location: Sterling, Virginia
Posts: 1,316
2.5-4.0tb issue

Swapping in a 4.0 tb to my 2.5. swapped all the sensors over, direct swap no issues. Went to fire it up and RAMPANT THROTTLE ISSUES. Throttle will not idle, will not calm down, full throttle and beyond instantly at start up. What gives? I followed the write ups out there, what am I missing?

Overhead is online now   Reply With Quote
Unread 01-17-2014, 10:06 PM   #2
apaTJ
Registered User
1999 TJ Wrangler 
 
Join Date: May 2013
Location: Louisville, Kentucky
Posts: 318
Quote:
Originally Posted by Overhead
Swapping in a 4.0 tb to my 2.5. swapped all the sensors over, direct swap no issues. Went to fire it up and RAMPANT THROTTLE ISSUES. Throttle will not idle, will not calm down, full throttle and beyond instantly at start up. What gives? I followed the write ups out there, what am I missing?
I have no experience with the swap, but my jeep did that after a tree fell in it, and it was a throttle linkage that was bent/extended.
apaTJ is offline   Reply With Quote
Unread 01-18-2014, 05:21 AM   #3
Jeepsr4me
Registered User
 
Join Date: Dec 2004
Posts: 4,084
Yeah look to see if the throttle plates are being held open. Also check for vacuum leaks.
Jeepsr4me is offline   Reply With Quote
Unread 01-20-2014, 08:57 PM   #4
Overhead
You built a 4cyl?
 
Overhead's Avatar
1995 YJ Wrangler 
 
Join Date: May 2011
Location: Sterling, Virginia
Posts: 1,316
no vacuum leaks, no stuck throttle, nothing pinched, just took off one of the 4.0 sensors and reinstalled it when I was doing the swap, as opposed to switching it for the 2.5tb sensors like I was supposed to. Simple mix up that had a bunch of people trying to figure it out. Thanks to TR. who figured it out and got me on the road!
Overhead is online now   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.