1995 yj taillight and turn signal issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 05-04-2014, 06:53 PM Thread Starter
FrostyBryan
Registered User
1995 YJ Wrangler 
 
Join Date: May 2014
Location: Frisco
Posts: 4
1995 yj taillight and turn signal issues

Hi there my name is Bryan and I own a 1995 jeep yj. ive used jeep forums alot for almost everything and anything I had to do to my jeep and I've been having this problem for a while, and to sum it up.. The brake lights wont turn on when I press the brakes, and also my turn signals/hazards wont turn on either. I've changed and replaced the bulbs, then replaced and checked all the fuses. Changed the flasher relay switch and hazard switch. And its still broken? I don't know what else to do.

https://www.youtube.com/watch?v=h-xPBVkpx5w for the video

FrostyBryan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-04-2014, 07:21 PM
Caboose89
Registered User
1989 YJ Wrangler 
 
Join Date: Jan 2014
Location: La Grande
Posts: 243
Make sure your tail lights are grounded.

1989 Sahara. SOA, 35's, Locked.
Caboose89 is offline  
post #3 of 6 Old 05-04-2014, 07:34 PM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,699
the tail lights ground through the mounting studs. Clean the studs and where they mount to the tub.

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
 
post #4 of 6 Old 05-10-2014, 11:19 AM Thread Starter
FrostyBryan
Registered User
1995 YJ Wrangler 
 
Join Date: May 2014
Location: Frisco
Posts: 4
Ok thank you I will try that
FrostyBryan is offline  
post #5 of 6 Old 05-10-2014, 10:48 PM
dukeryder
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2008
Location: Boulder
Posts: 141
after you clean up the contact surfaces with some scotch brite, squirt some WD-40 on the mounting surfaces and put a Dielectric grease on the bulb's contacts. That should help. I have a small utility trailer and I had one side acting the same way, no tail light, brake, or signal, I cleaned up the contacts and ******d it with WD and everything works great now.
dukeryder is offline  
post #6 of 6 Old 05-11-2014, 07:27 AM
Jpiombo
Registered User
1987 YJ Wrangler 
 
Join Date: Apr 2014
Location: Traverse City
Posts: 5
I just had the same problem.
I replaced the left rear turn signal, because it was rusting out.
Made sure all the bulbs were the right ones. I had 2057's in the front turn signals.
Retraced all the wires and found that I had a frayed wire on the right rear side of the jeep and it was causing everything to go haywire.
Check you fuses.

Hope this helps

The difference between my vehicle and yours is that my vehicle won a war.
Jpiombo is offline  
Reply

Tags
1995 , brake , jeep yj , taillight

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome