1995 Wrangler Speedometer not working - Page 2 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #16 of 35 Old 02-06-2013, 03:59 AM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,687
Quote:
Originally Posted by XJ93 View Post
Not sure if you guys in the older YJ's are aware of this, the OP's Jeep (as well as my 95) use an electronic sensor instead of gear and cable. Most likely issue is the vss (vehicle speed sensor). I just had mine go out three days ago.
while some of this is true... its still an easy check to spin the gear in a drill no matter what the year is... That way you can know if everything after the gear is good.


1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
Sponsored Links
Advertisement
 
post #17 of 35 Old 03-05-2013, 03:39 PM
XJ93
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: Michigan
Posts: 1,539
Which gear are you talking about Mark? best of my knowledge there isn't any way to attach a drill to the VSS end, and seems like an awful lot of work to go that route when you can just change the VSS and be done with it.
XJ93 is offline  
post #18 of 35 Old 03-05-2013, 03:50 PM
PA_YJ19
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2011
Location: Altoona
Posts: 1,137
The speedo gear in the tail shaft of ur TC tail cone or sye. Pull it out with the sensor still attached, put the other end of the gear in ur drill, then turn on ur jeep and spin the drill. If it works then te gear isn't clocked correctly, if it doesn't then ur sensor is bad. Like he said, it's a simple and Easy test. Remove 3 bolts and pull the gear out...
PA_YJ19 is offline  
post #19 of 35 Old 03-12-2014, 03:37 PM
Dan84
Registered User
1995 YJ Wrangler 
 
Join Date: Mar 2014
Location: Accokeek
Posts: 3
hi everyone I'm new in this forum and in the jeep world however I've already did lots of work on my jeep , I have a wrangler 1995 yj
My speedometer stop working but sometimes jumps and it dies again
Long story short I changed the tires a couple of weeks ago when started to fail but fixed the problem by replacing the speed sensor and the speedometer gear
A couple of days ago my Exhaust cracked and I had to replaced it had to removed the air box , steering pump , intake etc but I think I most connected something wrong because my speedometer won't work I have checked all connections many time but can't resolved the issue
I've also been doing some research and found that could be a bad TPS BUT EVERYTHING WAS FINE UNTILL I change the exhaust
Please help any ideas or similar issues here ?
Is annoying problem
Thanks
Dan84 is offline  
post #20 of 35 Old 03-12-2014, 07:12 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,800
Check the wiring to the sensor on the tcase.
Que89YJ is offline  
post #21 of 35 Old 03-24-2014, 08:49 PM
Dan84
Registered User
1995 YJ Wrangler 
 
Join Date: Mar 2014
Location: Accokeek
Posts: 3
Speedometer not working

Thanks I will try this tomorrow I was out of town last week but Seems weird to me because I replace the speed sensor over a month ago and also change the gear but after replacing the exhaust it stooped working and sometime it works but jumps a lot ....

Thanks again
Dan84 is offline  
post #22 of 35 Old 04-24-2014, 09:12 PM
Redqman
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2014
Location: Oskaloosa
Posts: 5
I have a 95 wrangler and changed the speed sensor with no luck. I do have the check engine light come on. to me that means wiring as I believe the light reads to see if the speed sensor is there is all. if someone knows different please let me know. it was out when I bought it. they told me it quit when the transfer case was replaced. I would like any clues.
Redqman is offline  
post #23 of 35 Old 04-25-2014, 07:57 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,800
Redgman post up to a new thread. Chances are you just need to clock the sensor which is nothing more then turning it to make the gears mesh. You can check functionality by pulling the speedo sensor putting the sensor in a drill and spinning it to see if you get an reading on the gauge.
Here is how to check your codes:
http://www.jeepforum.com/forum/f12/h...codes-1257145/
Que89YJ is offline  
post #24 of 35 Old 04-30-2014, 08:56 AM
Dan84
Registered User
1995 YJ Wrangler 
 
Join Date: Mar 2014
Location: Accokeek
Posts: 3
Fixed Spedo Problem

So after wasting time checking the spedo wiring etc, I disconnected the speed sensor from the Tcase and noticed that the Speedo gear was all broken and the pin the goes inside the gear was broken as well .. I was surprise because I bought it like 2 month ago although i only paid like $15 dollars thats why .. so if you are buying a speed sensor make sure it come from a good vendor or the dealer I know it will cost more but less headache you know

bottom line if you spedo stop working before wasting time checking on cables focus on the speed sensor it self and gear
Dan84 is offline  
post #25 of 35 Old 05-05-2014, 07:03 PM
Redqman
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2014
Location: Oskaloosa
Posts: 5
My speed sensor looks as well as the one removed. the speedometer say like 120 all the time. I am guessing bad speedometer but have no way to tell. the check engine light comes on every time I drive it.
Redqman is offline  
post #26 of 35 Old 05-05-2014, 07:41 PM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,687
as I have said before in this thread. Remove the vss (and the gear) from the transfer case. Turn the key to on (dont start it) and spin the gear in a drill. If the speedometer works then your wiring/speedo is good and you need to look after the gear... meaning clocked wrong, gear broken etc..

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
post #27 of 35 Old 05-06-2014, 12:05 PM
XJ93
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: Michigan
Posts: 1,539
Redqman you should pull the codes if your check engine light is on. One of those codes will probably point to the vss signal.
XJ93 is offline  
post #28 of 35 Old 05-07-2014, 07:49 PM
Redqman
Registered User
1995 YJ Wrangler 
 
Join Date: Apr 2014
Location: Oskaloosa
Posts: 5
the code is for the speed sensor but I don't beleive it is the sensor, it has been changed twice and the speedometer is pegged out at like 120 even when its off, that is wy I believe it to be something else.
Redqman is offline  
post #29 of 35 Old 05-07-2014, 08:57 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,800
You are backfieeding through the wiring. Do you have a meter?
Que89YJ is offline  
post #30 of 35 Old 05-08-2014, 09:08 AM
XJ93
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: Michigan
Posts: 1,539
That's why I asked for the code. What is the specific code? There are at least three that I know refer to the speed sensor. Knowing which code will help us point you in the right direction.
XJ93 is offline  
Reply

Tags
odometer , speedometer , wrangler

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Speedometer not working..... youngjeeper11 YJ Wrangler Technical Forum 7 10-13-2012 12:12 AM
Speedometer not working w9kh_kevin TJ Wrangler Technical Forum 3 10-19-2009 06:17 PM
1995 YJ 4x4 not working underpowered YJ Wrangler Technical Forum 13 10-10-2008 11:28 PM
Speedometer not working on 87 Wrangler 89 JeepYJ YJ Wrangler Technical Forum 5 03-20-2008 06:28 PM
Speedometer not working Cross Eyed TJ Wrangler Technical Forum 1 01-31-2006 05:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome