1995 wrangler rebuild wont start! help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 1995 wrangler rebuild wont start! help

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 04-17-2013, 01:41 PM   #1
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
1995 wrangler rebuild wont start! help

hey everyone i got a 1995 2.5 l wrangler and the engine threw a rod a week ago so i ripped the engine out and brought it to the rebuild shop it got done being rebuilt and i got done installing everything and when i tried to turn it over the starter just makes a constant clicking noise and wont start..The starter is brand spankin new and so is the battery! i tryed to turn the crank by hand with a ratchet and it was extremely hard to turn so i think that has something to do with it! this is my everyday driver so i need to figure this out!thank you

wyattwj123 is offline   Reply With Quote
Unread 04-17-2013, 01:45 PM   #2
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples, FL
Posts: 589
Pull the plugs and see if it turns over by hand that way....

Assuming shop has everything all done with assembly lube and you primed the oiling system??
__________________
Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline   Reply With Quote
Unread 04-17-2013, 02:28 PM   #3
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
i will try that with the plugs and if it cranks what does that mean?! and yes but i dont even know what priming the oil system is hahah
wyattwj123 is offline   Reply With Quote
Unread 04-17-2013, 05:36 PM   #4
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
Anyone????????????? Any help would be great thank you!!
wyattwj123 is offline   Reply With Quote
Unread 04-17-2013, 06:09 PM   #5
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,756
It sounds like the starter is binding. You need to check that they gave you the right starter. Drop the starter and see if it actuates. If it does then. Pull the plugs so you are not dealing with the engines compression and turn it with a wrench on the crank pulley. If it is hard to spin the issue is in the engine.
Que89YJ is offline   Reply With Quote
Unread 04-17-2013, 06:14 PM   #6
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
ok ill do that tomorrow but the starter is the same one i had before that is brand new but the new remaned one could be bad i guess but will do thank you
wyattwj123 is offline   Reply With Quote
Unread 04-17-2013, 06:28 PM   #7
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,756
Lets hope so. That u=is what Flcracker was talking about.
Que89YJ is offline   Reply With Quote
Unread 04-17-2013, 06:37 PM   #8
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
Yea I really hope so but the engine is freshly rebuilt should be no issues but ill try it an what is priming the oil?
wyattwj123 is offline   Reply With Quote
Unread 04-17-2013, 07:03 PM   #9
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples, FL
Posts: 589
Quote:
Originally Posted by wyattwj123 View Post
Yea I really hope so but the engine is freshly rebuilt should be no issues but ill try it an what is priming the oil?
More experience with small block cbevys back in the day but priming the oil system is putting a gutted distributor down to engage oil pump and driving the oil pump with a drill to pump oil throughout the engine..
__________________
Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline   Reply With Quote
Unread 04-17-2013, 07:29 PM   #10
pete1991YJ
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2012
Location: Niagara Falls, NY
Posts: 1,628
Quote:
Originally Posted by flcracker View Post
More experience with small block cbevys back in the day but priming the oil system is putting a gutted distributor down to engage oil pump and driving the oil pump with a drill to pump oil throughout the engine..
You can do the same thing with an old screwdriver in an electric drill. Its a pretty good idea too.
__________________
***--- Wrecking Crew member ---***
"I've prolly been around longer than you think"
pete1991YJ is offline   Reply With Quote
Unread 04-17-2013, 08:07 PM   #11
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
Won't it work if I remove the spark slugs and try and turn it over?!
wyattwj123 is offline   Reply With Quote
Unread 04-17-2013, 08:20 PM   #12
pete1991YJ
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2012
Location: Niagara Falls, NY
Posts: 1,628
I wonder if this is one of those got the backside of a pulley hung up on the block somewhere. I remember a guy had that problem last year. It totally baffled him because nobody expected the obvious to check.
__________________
***--- Wrecking Crew member ---***
"I've prolly been around longer than you think"
pete1991YJ is offline   Reply With Quote
Unread 04-18-2013, 06:58 AM   #13
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
Pulled the plugs it was a bit easier to turn the crank but the starter did the same thing :/
wyattwj123 is offline   Reply With Quote
Unread 04-18-2013, 07:25 AM   #14
pete1991YJ
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2012
Location: Niagara Falls, NY
Posts: 1,628
Hrmm, the starter is new and so is the battery... what about the cables? and the connectors? A cable thats corroded inside will do that. Also is it grounded? If so, are the grounds clean and tight? The engine needs a ground as big as the starter cable.
__________________
***--- Wrecking Crew member ---***
"I've prolly been around longer than you think"
pete1991YJ is offline   Reply With Quote
Unread 04-18-2013, 07:48 AM   #15
wyattwj123
Registered User
2000 WJ 
 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
Yes everything is good I just got another starter and wired it up when I put the ground on the battery the starter just started spinning all the wires are connected correctly
wyattwj123 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.