1995 Jeep Wrangler turn/hazard lights - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 1995 Jeep Wrangler turn/hazard lights

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitSavvy Billet LED Tail LightsSavvy FOX IFP 4" Lift Shocks in Stock

Reply
Unread 08-14-2011, 12:03 PM   #1
goffj4
Registered User
 
Join Date: Aug 2011
Location: Jefferson City, Tennessee
Posts: 1
1995 Jeep Wrangler turn/hazard lights

I've got a problem with my 1995 Jeep Wrangler left turn signal as well as my hazard lights. When I first got the jeep (roughly 2 years ago), the left turn signal light on the dash was constantly lit. At the same time, the driver-side running light (marker light), remained off unless the turn signal was on (in which case it blinked normally). Since it was a relatively small problem, I more or less ignored it. On occasion after turning, the dash light would go out, and the running light would stay on, but it was sporadic and unpredictable. All other lights functioned properly. After some time (maybe 6 months) the light on the dash no longer stayed lit, though it worked properly for turning; however, the running light remained off (except when the turn signal was on).

Within the past year, I've had some other problems arise. The left turn signal situation remained the same: the left running light works properly for turn signals, but does not turn on with the rest of the lights. Suddenly, however, my hazard lights ceased to work. I would pull the switch and hear the clicking, but no lights in either the dash or the exterior.

I have no idea if these problems are inter-related, nor the slightest clue how to fix them and was hoping some of you folk might have some advice. As a note, i have changed the left running light bulb twice to no effect, as well as the battery (the original finally died). The battery was replaced after the most recent evolution of the light problem and since replacement has had no effect.

Any help is much appreciated! Thanks!

goffj4 is offline   Reply With Quote
Unread 08-14-2011, 03:31 PM   #2
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,303
take off the left rear tail light and clean the mounting studs. The light gets its ground from there and may fix the rest of your problems as well.
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote
Unread 08-14-2011, 05:57 PM   #3
jay-h
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2006
Location: , NJ
Posts: 4,348
Odd behaviors like that are often grounding problems.
jay-h is offline   Reply With Quote
Unread 08-14-2011, 06:09 PM   #4
5.7YJ
Senior Member
 
5.7YJ's Avatar
1987 YJ Wrangler 
 
Join Date: Aug 2006
Location: Rockledge, Florida
Posts: 898
Definitely sounds like a ground issue.
__________________
87 YJ, TPI 5.7, 700R4, NP231, BDS 3.5" lift, 1" front & 5/8" rear boomerang shackles, Rubicon Dana 44 rear axle, 33" Goodyear Duratracs











My brake boster/master cylinder upgrade: http://www.jeepforum.com/forum/f12/9...grade-1287758/
5.7YJ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.