1994 YJ Oil Pressure goes down - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > 1994 YJ Oil Pressure goes down

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-01-2013, 12:16 PM   #1
sherrodk
Registered User
1994 YJ Wrangler 
 
Join Date: Oct 2009
Location: Tennessee
Posts: 11
1994 YJ Oil Pressure goes down

I have this problem where my oil pressure will be between 40 and 50 when its first started, than after about 10 minutes of driving it will drop down to 0 to 10. It will stay there. I have changed the oil and filter, and the oil sending unit but has not helped. Any ideas. Also do not see any oil leaks at all.

1994 YJ 2.5 with 120,000 miles

sherrodk is offline   Reply With Quote
Unread 05-01-2013, 07:25 PM   #2
RustedWrangler
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2009
Location: Bristow, VA
Posts: 601
Mine drops to about 25-30. Probably time for both of us to think about replacing oil pumps.
__________________
www.RCPFA.com
RustedWrangler is offline   Reply With Quote
Unread 05-02-2013, 10:50 AM   #3
cojab
Senior Member
 
cojab's Avatar
1993 YJ Wrangler 
 
Join Date: Oct 2010
Location: , Colorado
Posts: 525
I have the same issue. I read a thread on here a couple of weeks ago about another member that had the same issue also. I'm sure I wont remember this completely correctly but the jest of his thread was that while troubleshooting he removed his sending unit I believe, cleaned the oil passages and problem solved. Gauge has read correctly at about 40psi since. He had feedback from others on that thread that did the same fix with same results. Worth a shot before dropping the pan for a pump.
Hopefully someone else has better details or the link to that thread for you. You might try a quick search for it also. I know the info is in here somewhere. Next time I find it I wont be such a knucklehead and I'll bookmark it since I need to do this as well.
cojab is offline   Reply With Quote
Unread 05-02-2013, 11:30 AM   #4
skyj
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2011
Location: Helena, MT
Posts: 2,763
It could be a number of things, start with the easy one others have suggested. It could so be your main and rod bearings on the crank or the cam bearings. Usually that's the case when you start up and you get high pressure cause the oil is not as thin as it is when it was a cold motor, then as the motor warms and the oil thins a bit and you drop pressure.
__________________
build thread: http://www.jeepforum.com/forum/f22/skyj-eccentric-build-1467426/ '90 YJ 5.2 magnum MPI, AX15, NP231 SYE, Dana 30 4.56 open/ 8.8 4.56 detriot locker. 1" shackles
2" BL, 4" stretch all on saggy waggy springs.
skyj is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.