1992 Jeep Wrangler, Wont Start, No Spark - JeepForum.com

 
LinkBack Thread Tools
post #1 of 14 Old 01-16-2015, 07:13 AM Thread Starter
bigjeepman
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2005
Location: New Albany, IN
Posts: 64
1992 Jeep Wrangler, Wont Start, No Spark

1992 Wrangler 4cyl 5 speed.

Will crank for days, no spark, Power going to coil, no spark coming out.

Coil, Distributor Pickup and Cranskahft position Sensor are all brand new. Check engine light comes on when key is turned on, goes out after a minute or two. When I do the engine code procedure it Has shown code 54 repetitively since I replaced distributor pickup. All fuses are good. I have swapped the ASD relay with another working relay.

I always thought if the check engine light comes on it signals the PCM is good

Any ideas? I have turned wrenches on jeeps for years and have never had one this frustrating. Im at a loss. I have read everything under the sun on what it could be. I have spare, known good pickup, cps, and coil at my disposal.


1992 YJ WRANGLER
1998 GRAND CHEROKEE
bigjeepman is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 01-16-2015, 03:42 PM
andyldavis
Registered User
1993 YJ Wrangler 
 
Join Date: Jun 2014
Location: Apopka
Posts: 63
Code 54

Code 54> no cam sync signal seen at PCM. Bad wire, bad cam sensor.
andyldavis is offline  
post #3 of 14 Old 01-16-2015, 05:34 PM
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
2010 JK Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,926
Quote:
Originally Posted by bigjeepman View Post
1992 Wrangler 4cyl 5 speed.

Will crank for days, no spark, Power going to coil, no spark coming out.

Coil, Distributor Pickup and Cranskahft position Sensor are all brand new. Check engine light comes on when key is turned on, goes out after a minute or two. When I do the engine code procedure it Has shown code 54 repetitively since I replaced distributor pickup. All fuses are good. I have swapped the ASD relay with another working relay.

I always thought if the check engine light comes on it signals the PCM is good

Any ideas? I have turned wrenches on jeeps for years and have never had one this frustrating. Im at a loss. I have read everything under the sun on what it could be. I have spare, known good pickup, cps, and coil at my disposal.
Unplug the VSS sensor from the tranny. Then attempt to start it up. If it does the VSS sensor is NG.

Do you know what was good about the good old days? I wasn't good, And I wasn't old!

Senators and Congressman should wear uniforms like NASCAR drivers so we could identify their corporate sponsors....
laybackman is offline  
post #4 of 14 Old 01-29-2015, 07:32 PM Thread Starter
bigjeepman
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2005
Location: New Albany, IN
Posts: 64
Still need help. I unplugged the VSS with no change.

Removed ASD relay and replaced with another.

Tried cranking and I'm getting nothing. I check the codes and it is showing camshaft position sensor (under distributor), replaced it and try again. Same thing. At this point I have checked all fuses, I've ensured the distributor shaft is turning.

I need help. Anyone have any ideas?
bigjeepman is offline  
post #5 of 14 Old 01-30-2015, 06:14 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,945
Big, do a battery reset to clear all the codes crank it and recheck codes and post them. Did you replace the pickup or the entire distributor?
Que89YJ is online now  
post #6 of 14 Old 01-30-2015, 10:22 AM Thread Starter
bigjeepman
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2005
Location: New Albany, IN
Posts: 64
Que, I have done that and still get the pickup coil code.

I just replaced the pickup. I Have power going into the coil but nothing coming out. Coil is brand new as well. Cps is new.
bigjeepman is offline  
post #7 of 14 Old 01-30-2015, 10:31 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,945
First things first do you have a meter? Also basics, the ecu is not receiving the pulse. Look at the connection on the pickup and make sure there are no pushed pins when you put the connectors together. Also pull the cap and make sure the rotor is spinning when you are cranking. The gears on the distributor have been known to fail. We will get you going.
Que89YJ is online now  
post #8 of 14 Old 01-31-2015, 05:23 AM Thread Starter
bigjeepman
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2005
Location: New Albany, IN
Posts: 64
I do have a meter. The rotor does turn, I pulled the distributor because the pickup resembles a newer pickup that uses the two screws that hold the cap down to retain it. I got the one that the parts stores advise as a replacement. Going to disassemble the distributor today and put the replacement pickup in.
bigjeepman is offline  
post #9 of 14 Old 01-31-2015, 08:20 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,945
Consider the entire setup with the distributor and pickup. They are about 60

Post what happens
Que89YJ is online now  
post #10 of 14 Old 02-01-2015, 05:15 PM Thread Starter
bigjeepman
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2005
Location: New Albany, IN
Posts: 64
Replaced distributor and it fired right up. I'm all good with that but don't understand why. The distributor turned and everything was fine. Makes no sense to me, but non the less, it runs.

Thank you for your help
bigjeepman is offline  
post #11 of 14 Old 02-01-2015, 07:06 PM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,699
there is a pickup in the distributor.. sounds like yours was bad... when you changed the distributor you changed the pickup inside it.

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
post #12 of 14 Old 02-02-2015, 03:04 AM Thread Starter
bigjeepman
Registered User
1992 YJ Wrangler 
 
Join Date: Nov 2005
Location: New Albany, IN
Posts: 64
I had repaced the pickup 3 or 4 times already. No big deal just puzzles me
bigjeepman is offline  
post #13 of 14 Old 02-02-2015, 03:31 AM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,699
well maybe it wasnt the pickup then... but was obviously something internal to the distributor

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
post #14 of 14 Old 02-02-2015, 03:11 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,945
I get it right every now and then.
Que89YJ is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome